httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pieter Donche <Pieter.Don...@ua.ac.be>
Subject [users@httpd] problem installing DSO module
Date Tue, 10 Feb 2009 15:29:47 GMT
I want to install mod_expires in our Apache2.2.9 as a DSO.
My Apache has mod_so and is installed in /home/apache_229bis
My Apache sources are in /home/wins/builds/src/other/httpd-2.2.9

# /home/apache_229bis/bin/apxs -c /home/wins/builds/src/other/httpd-2.2.9/module
s/metadata/mod_expires.c
creates in /home/wins/builds/src/other/httpd-2.2.9/modules/metadata/

drwxr-xr-x    2 root     root          512 Feb 10 15:08 .libs
-rw-r--r--    1 root     root          823 Feb 10 15:08 mod_expires.la
-rw-r--r--    1 root     root          381 Feb 10 15:08 mod_expires.lo
-rw-r--r--    1 root     root        30004 Feb 10 15:08 mod_expires.o
-rw-r--r--    1 root     root            0 Feb 10 15:08 mod_expires.slo
and in the subdir .libs:
-rw-r--r--    1 root     root        30156 Feb 10 15:08 mod_expires.a
lrwxrwxrwx    1 root     root           17 Feb 10 15:08 mod_expires.la -> ../mod
_expires.la
-rw-r--r--    1 root     root          824 Feb 10 15:08 mod_expires.lai
-rw-r--r--    1 root     root        30004 Feb 10 15:07 mod_expires.o
-rwxr-xr-x    1 root     root        30164 Feb 10 15:08 mod_expires.so

The next step is:
# /home/apache_229bis/bin/apxs -i -a mod_expires.la
apxs:Error: Sorry, cannot determine bootstrap symbol name.
apxs:Error: Please specify one with option `-n'.

OK, I try with an option -n   (tried with "expires" with or without "")

# /home/apache_229bis/bin/apxs -i -a -n "expires" mod_expires.la
/home/apache_229bis/build/instdso.sh SH_LIBTOOL='/home/apache_229bis/build/libto
ol' mod_expires.la /home/apache_229bis/modules
/home/apache_229bis/build/libtool --mode=install cp mod_expires.la /home/apache_
229bis/modules/
libtool: install: `mod_expires.la' is not a valid libtool archive
Try `libtool --help --mode=install' for more information.
apxs:Error: Command failed with rc=65536


What's wrong here and how to solve this ?
Thanx for any help...


mod_expires.la contains:
-----------------------------------------------
# mod_expires.la - a libtool library file
# Generated by ltmain.sh - GNU libtool 1.5.26 (1.1220.2.492 2008/01/30 06:40:56)
#
# Please DO NOT delete this file!
# It is necessary for linking the library.

# The name that we can dlopen(3).
dlname='mod_expires.so'

# Names of this library.
library_names='mod_expires.so mod_expires.so mod_expires.so'

# The name of the static archive.
old_library='mod_expires.a'

# Libraries that this one depends upon.
dependency_libs=''

# Version information for mod_expires.
current=0
age=0
revision=0

# Is this an already installed library?
installed=no

# Should we warn about portability when linking against -modules?
shouldnotlink=yes

# Files to dlopen/dlpreopen
dlopen=''
dlpreopen=''

# Directory that this library needs to be installed in:
libdir='/home/apache_229bis/modules'
-----------------------------------------------


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message