httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jon Foster <jon-li...@jfpossibilities.com>
Subject [users@httpd] Apache 2.2.11 mostly not serving files
Date Tue, 03 Feb 2009 02:23:43 GMT
I've run into a strange situation. I've been running Apache 2.0.59 with
mod_ssl and PHP 4.4.7 built from source on a SuSE 9.0 box. I recently
attempted upgrading to APR 1.3.3, apr-util 1.3.4, Apache 2.2.11 and PHP
4.4.9. What happened has left me at a loss as to what to look at to fix
it! All of the dynamically generated content and the content served by
mod_ssl is ok. However files off of the file system much larger than 250
bytes never make it to the client side. This is primarily images but it
happens with any static file that is larger than ~250 bytes, unless its
served over HTTPS.

I haven't done exhaustive testing by looking at the supplied '/icons/'
folder all images around 250 bytes and smaller are transferred to the
client and everything else including the README and README.html files won't.

The access logs show the request and the correct file size but usually
firefox just shows a blank file. Wget returns a "no content" error.

Rolling back to Apache 2.0.59 has fixed everything.

THX - Jon

-- 
Jon Foster
JF Possibilities, Inc.
jon@jfpossibilities.com
541-410-2760
Making computers work for you!


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message