httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Matt McCutchen <m...@mattmccutchen.net>
Subject Re: [users@httpd] mod_proxy not displaying images
Date Tue, 17 Feb 2009 18:03:58 GMT
On Tue, 2009-02-17 at 11:59 -0500, Christopher Long wrote:
> I'm attempting to use mod_proxy to display various webpages via
> ProxyPass.  I'm having issues getting the images to properly come
> through.  Here is what I have in /conf/httpd.conf:
> 
> 
> <IfModule proxy_module>
> 
> ProxyRequests Off
> 
> <Proxy *>
>    Order deny,allow
>    Allow from all
> </Proxy>
> 
> ProxyPass        /google/ http://www.google.com/
> ProxyPassReverse    /google/ http://www.google.com/
> 
> </IfModule>
> 
> And this is the error I am receiving in /logs/error.log:
> 
> [Tue Feb 17 11:54:21 2009] [error] [client 127.0.0.1] File does not
> exist: D:/httpd/htdocs/intl, referer: http://localhost/google/
> [Tue Feb 17 11:54:21 2009] [error] [client 127.0.0.1] File does not
> exist: D:/httpd/htdocs/extern_js, referer: http://localhost/google/
> [Tue Feb 17 11:54:21 2009] [error] [client 127.0.0.1] File does not
> exist: D:/httpd/htdocs/images, referer: http://localhost/google/
> 
> Does anyone know how I can get these errors to go away and have the
> images display?

You probably need to use mod_proxy_html to rewrite image references in
the HTML, as mentioned in the ProxyPassReverse documentation.  I also
suggest that you try a test case other than Google in case Google tries
to block people from proxy-passing to them.

-- 
Matt


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message