httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nick Kew <n...@webthing.com>
Subject Re: [users@httpd] mod_authn_dbd/mod_dbd problem with oracle
Date Mon, 12 Jan 2009 21:33:41 GMT
On Mon, 12 Jan 2009 10:02:46 -0800 (PST)
RJones1 <randy_jones@esri.com> wrote:

> 
> I'm running Apache 2.2.11 with ssl on windows and can't seem to get
> the configuration right to use oracle for authentication. I've been
> searching for a day now and can't find anything to help me make real
> progress.

Thanks for the report.  This looks challenging.

> When I start I get the following errors:
> [error] (OS 126)The specified module could not be found.  : DBD:
> mod_dbd not compatible with APR in get_driver
> [error] (OS 126)The specified module could not be found.  : DBD:
> failed to initialise

OS 126 is an error from an operating system call.  The text
"The specified module could not be found." comes from the OS,
not from Apache or APR.  So that looks like your best clue:
where is your apr_dbd_oracle.so (or .dll)?, and do you need
to modify some system path to help find it?  Google finds
lots of reports of that error in other apps.

The "not compatible with APR" is a check I put in there, and it
means apr_dbd or the driver is returning an error that's not
handled by mod_dbd: when I originally wrote that code, every
error that apr_dbd could return there was handled.
Unfortunately that doesn't help with diagnosing it.

-- 
Nick Kew

Application Development with Apache - the Apache Modules Book
http://www.apachetutor.org/

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message