httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Paul Herring" <pauljherr...@gmail.com>
Subject Re: [users@httpd] Re: Apache 2.2.10 - apxs - cross-compiling modules failing
Date Fri, 05 Dec 2008 14:11:56 GMT
On Fri, Dec 5, 2008 at 12:53 PM, Nick Kew <nick@webthing.com> wrote:
> On Fri, 5 Dec 2008 08:17:38 +0000
> "Paul Herring" <pauljherring@gmail.com> wrote:
>
>> It's been a week since I posted this, and (possibly not surprisingly)
>> I've had no replies.
>>
>> Is it because I've supplied insufficient detail, I'm asking in the
>> wrong place, or because the apache/httpd/apxs build simply isn't
>> designed to be cross-compiled.
>
> Dunno, I've not tried it.
>
> How about telling us what happened when you just tried using
> the apxs from a build cross-compiled for your target platform?

Copy/paste from the mod_python list from my initial stab at finding a solution:

Version of mod_python: 3.3.1
Apache: 2.2.10
Python: 2.4.4 (I realise this is an old version, but this was
requested due to compatibility issues with other software that's
used.)

configure without apxs:
------------->8===========
./configure --build=i586-cross-linux-gnu --host=i686-pc-linux-gnu \
               --prefix=/f15_nsb
checking for i686-pc-linux-gnu-gcc... i686-pc-linux-gnu-gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... yes
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether i686-pc-linux-gnu-gcc accepts -g... yes
checking for i686-pc-linux-gnu-gcc option to accept ANSI C... none needed
checking for ar... i686-pc-linux-gnu-ar
checking for a BSD-compatible install... /usr/bin/install -c
checking whether make sets $(MAKE)... yes
checking for main in -lm... yes
checking for an ANSI C-conforming const... yes
checking your blood pressure... a bit high, but we can proceed
configure: checking whether apxs is available...
checking for --with-apxs... no
checking for apxs in /usr/local/apache/sbin... no
checking for apxs in your PATH... checking for apxs... no
checking for apxs2 in your PATH... checking for apxs2... no
configure: WARNING: **** apxs was not found, DSO compilation will not
be available.
configure: WARNING: **** You can use --with-apxs to specify where your apxs is.
configure: error: Neither static nor DSO option available, there is no
point in continuing.
------------->8===========

configure using target version of apxs:

------------->8===========
./configure --build=i586-cross-linux-gnu --host=i686-pc-linux-gnu \
               --prefix=/f15_nsb \
               --with-apxs=/f15_nsb/usr/local/bin/apxs
checking for i686-pc-linux-gnu-gcc... i686-pc-linux-gnu-gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... yes
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether i686-pc-linux-gnu-gcc accepts -g... yes
checking for i686-pc-linux-gnu-gcc option to accept ANSI C... none needed
checking for ar... i686-pc-linux-gnu-ar
checking for a BSD-compatible install... /usr/bin/install -c
checking whether make sets $(MAKE)... yes
checking for main in -lm... yes
checking for an ANSI C-conforming const... yes
checking your blood pressure... a bit high, but we can proceed
configure: checking whether apxs is available...
checking for --with-apxs... /f15_nsb/usr/local/bin/apxs executable, good
checking Apache version... cannot open
/usr/local/conf/build/config_vars.mk: No such file or directory at
/f15_nsb/usr/local/bin/apxs line 218.
cannot open /usr/local/conf/build/config_vars.mk: No such file or
directory at /f15_nsb/usr/local/bin/apxs line 218.
 running %/% cannot open /usr/local/conf/build/config_vars.mk: No such
file or directory at /f15_nsb/usr/local/bin/apxs line 218.
cannot open /usr/local/conf/build/config_vars.mk: No such file or
directory at /f15_nsb/usr/local/bin/apxs line 218.
./configure: line 2714: /: is a directory

configure: error: This version of mod_python only works with Apache 2.
The one you have seems to be .
------------->8===========


-- 
PJH

http://shabbleland.myminicity.com/tra

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message