httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From jim huang <jim...@hotmail.com>
Subject [users@httpd] mod-ldap compile error
Date Sat, 22 Nov 2008 01:01:11 GMT

I try to install Apache server 2.2.10 on Centos 5.1. Without enable ldap module, everything
is ok.
But I continue getting compile error below when I try to enable ldap module.
 
server/.libs/libmain.a(exports.o):(.data+0xed4): undefined reference to `apr_ldap_ssl_init'server/.libs/libmain.a(exports.o):(.data+0xed8):
undefined reference to `apr_ldap_ssl_deinit'server/.libs/libmain.a(exports.o):(.data+0xedc):
undefined reference to `apr_ldap_init'server/.libs/libmain.a(exports.o):(.data+0xee0): undefined
reference to `apr_ldap_info'server/.libs/libmain.a(exports.o):(.data+0xee4): undefined reference
to `apr_ldap_get_option'server/.libs/libmain.a(exports.o):(.data+0xee8): undefined reference
to `apr_ldap_set_option'server/.libs/libmain.a(exports.o):(.data+0xeec): undefined reference
to `apr_ldap_rebind_init'server/.libs/libmain.a(exports.o):(.data+0xef0): undefined reference
to `apr_ldap_rebind_add'server/.libs/libmain.a(exports.o):(.data+0xef4): undefined reference
to `apr_ldap_rebind_remove'server/.libs/libmain.a(exports.o):(.data+0xef8): undefined reference
to `apr_ldap_is_ldap_url'server/.libs/libmain.a(exports.o):(.data+0xefc): undefined reference
to `apr_ldap_is_ldaps_url'server/.libs/libmain.a(exports.o):(.data+0xf00): undefined reference
to `apr_ldap_is_ldapi_url'server/.libs/libmain.a(exports.o):(.data+0xf04): undefined reference
to `apr_ldap_url_parse_ext'server/.libs/libmain.a(exports.o):(.data+0xf08): undefined reference
to `apr_ldap_url_parse'
There is a bug 38965 reported in 2.2.4 and looks very similar. https://issues.apache.org/bugzilla/show_bug.cgi?id=38965.
But even followed the suggestion, I still can't get my compiling work.
 
Here is my configuration command: 
./configure --prefix=/usr/local/apache2 --enable-modules=all --enable-mods-shared=all --enable-so
--enable-proxy --enable-proxy-ajp --enable-ssl --with-ssl --with-ldap --enable-ldap --enable-authnz-ldap
--with-ldap-lib=/usr/local/lib --with-ldap-include=/usr/local/include --with-apr=/usr/local/src/httpd-2.2.10/srclib/apr
--with-apr-util=/usr/local/src/httpd-2.2.10/srclib/apr-util
 
I installed latest version of openldap client and didn't get any error during configuration.
 
Thanks in advance for the help.
 
jim
_________________________________________________________________


Mime
View raw message