httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Multer <da...@multer.com>
Subject [users@httpd] httpd 2.2.10 mod_proxy bug?
Date Wed, 05 Nov 2008 06:30:04 GMT
I just installed the latest 2.2.10 version of Apache web server and  
noticed it's broken my Tomcat+Hudson setup. I've confirmed that  
falling back to 2.2.9 eliminates the problem. I suppose it could be an  
issue in my config that was only uncovered with the latest version,  
but for now I'll assume it's a real problem.

My httpd.conf:
...
LoadModule proxy_module modules/mod_proxy.so
...
ProxyRequests off
...
ProxyPass /hudson/ http://subdomain.domain.com:8080/hudson/
ProxyPassReverse /hudson/ http://subdomain.domain.com:8080/hudson/

Using 2.2.10, when I navigate to http://subdomain.domain.com:8080/hudson/ 
  everything works fine. So Tomcat+Hudson is good. When I go to http://subdomain.domain.com/hudson/

  I get a 502 GET /hudson/ error reporting a DNS failure for  
subdomain.domain.com. Again, both approaches work fine under 2.2.9.

Here's what shows up in my Apache error log:
[Tue Nov 04 16:04:55 2008] [error] [client X.X.X.X] proxy: DNS lookup  
failure for: subdomain.domain.com returned by /hudson/

Thanks for any help. I wanted to ask before filing a bug report.

-David


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message