httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Craig Tataryn <crai...@tataryn.net>
Subject [users@httpd] Rewrite help
Date Sat, 08 Nov 2008 16:26:03 GMT
Hi, I have the following rules setup:

-----------------
Alias /root-resources /Users/craiger/root-test

RewriteEngine On
RewriteRule ^/freshaire/images/(.*)$ /root-resources/images/$1 [L]

RewriteRule ^/freshaire/community/images/(.*)$ /root-resources/ 
community-resources/images/$1 [L]
-----------------

How, if I fire up a browser and type:
Everything is fine if I navigate to:
http://localhost/root-resources/community-resources/images/someimage.jpg

But here I get a 404:
http://localhost/freshaire/community/images/someimage.jpg

You can probably see what I'm trying to accomplish here, not sure why  
it's not working?

I'm running Apache 2.2 under Mac OSX 10.5.5.

Any help would be greatly appreciated.

Craig.

--
Craig Tataryn
site: http://www.basementcoders.com/
podcast:http://feeds.feedburner.com/TheBasementCoders
irc: ThaDon on freenode #basementcoders, ##wicket, #papernapkin
im: craiger316@hotmail.com, skype: craig.tataryn


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message