httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Issac Goldstand <mmsucces...@gmail.com>
Subject Re: [users@httpd] Apache worker / PHP issue
Date Tue, 11 Nov 2008 07:40:32 GMT
André Warnier wrote:
> Savio Dias wrote:
>> Hello,
>>
>> Is there anyone who can help resolve this issue ?
>>
> Hi.
> What the Debian packager (through the apt-get program) and Eric are
> telling you, is that the PHP5 package removes mpm-worker and replaces it
> by mpm-prefork for a good reason.
> The good reason is probably that mpm-worker is a threaded version of
> Apache, and PHP5 has something that does not work in a threaded version
> of Apache, so they are not compatible.
> 

That's correct.  To correctly run PHP5 in a threaded Apache, don't use
mod_php5 - use FastCGI.  That'll give you all of the benefits of worker
without bombing out on non-threadsafe PHP calls (or if you're POSITIVE
that you don't need threadsafe PHP5 extensions, you can use mod_php5 -
AFAIK the php5 core IS threadsafe and I know of several folks using this
in production)

  Issac


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message