httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nick Kew <n...@webthing.com>
Subject Re: [users@httpd] mod_proxy sends reverse proxy request twice
Date Thu, 27 Nov 2008 13:21:38 GMT
On Thu, 27 Nov 2008 00:20:56 -0700
"Ryan Warnick" <warnickr_1@isp01.net> wrote:

> It looks like for Apache 2.2.10 on Windows, mod_proxy sends reverse
> proxy requests twice.  I've verified this using two different packet
> sniffers.  I also tracked the problem to the 'WSAsend' winsock call.
> If you alter the APR to use the 'send' winsock API call instead of
> the WSAsend call, then the problem goes away.  I wonder if this is a
> winsock bug.

Speaking from complete ignorance of Windows ...

I expect if your experience were universal or even common, we'd've
been deluged with reports of it.  Have you reproduced it on different
windows versions, and perhaps on a 'clean' install without other
software that might affect your networking?

If it's changed in 2.2.10 vs 2.2.9 (or other recent version),
then maybe you should enter it in bugzilla.

-- 
Nick Kew

Application Development with Apache - the Apache Modules Book
http://www.apachetutor.org/

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message