httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kailas Narendran" <kai...@xitome.com>
Subject [users@httpd] VirtualHosts and WebDAV
Date Sat, 15 Nov 2008 00:53:38 GMT
Hi!  I'm trying to get webdav folders to work on my webserver.  I've got 2
virtual hosts served off one IP.

I've enabled virtual hosts by the instructions by creating a file with the
host name in /etc/apache2/sites-available/

(for example)

/etc/apache2/sites-available/mysite.org
/etc/apache2/sites-available/mysite.com

with contents that look like

<VirtualHost *>
        ServerAdmin kailas@mysite.com
        ServerName mysite.com
        ServerAlias mysite.com

        DirectoryIndex index.php
        DocumentRoot /var/www/wordpress/
</VirtualHost>

(mysite.org on the other one).

I've enabled WebDAV according to the instructions at
http://www.digital-arcanist.com/sanctum/article.php?story=20070427101250622.

The webDAV folder is to be accessible under by mysite.org (not mysite.com).
it didn't seem to work, as i can get to mysite.org/myWebDAV/ without any
authentication, and i can't get my windows network place to authenticate on
it.

I figured this probably required some changes from the exact instructions at
that website, and required me to add what the site instructed me to put in
httpd.conf in the virtual host file i created in
/etc/apache2/sites-available/.

So, i changed the file for mysite.org to look like this:

<VirtualHost *>
        ServerAdmin kailas@mysite.org
        ServerName mysite.org
        ServerAlias mysite.org

        DirectoryIndex main.php
        DocumentRoot /var/www

        ## Location of DavLock File
        DavLockDB /usr/share/apache2/var/DavLock

        ## setup myWebDav Directory
        <Directory "/var/www/myWebDAV">
        Dav On
        AuthName "WebDAV Login"
        AuthType Basic
        AuthUserFile /etc/apache2/.htpasswd
        <LimitExcept GET HEAD OPTION POST>
                require valid-user
        </LimitExcept>
        Order allow,deny
        Allow from all
        </Directory>

</VirtualHost>

That didn't work either.  anyone have any ideas what might be wrong?

Thanks in advance.

-kailas

Mime
View raw message