httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Thorsten Philipp" <thors...@kyri0s.de>
Subject [users@httpd] mod_headers not working for Content-Length
Date Fri, 21 Nov 2008 12:44:57 GMT
Hi,

I'd like to unset/modify the Content-Length for some Files. I know this is
propably not what everybody wants.

I was optimistic that I could do this with mod_headers. Unfortunatly it
doesn't seem to work at all.

I'm using debian Lenny with apache 2.2.9

Here is what I tried so far:

<Directory "somedir">
AllowOverride All
allow from all
Options -Indexes
Header edit Content-Length ^.* 9999
Header set MyTest Foo
</Directory>


I see the Header MyTest in the server's response. So I assume the module is
working. Unfortunatly the Content-Length is still reported with the original
size.

I also tried to use the following statements.

Header edit Content-Length .* 9999
Header unset Content-Length
Header set Content-Length 1

I wonder if someone has experienced such behaviour before. I wouldn't like
to implement some CGI Stuff for that.

Bye
Kyrios

Mime
View raw message