httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Francois Gingras" <francois.ging...@gmail.com>
Subject Re: [users@httpd] Apache not executing Perl script,but perl script is getting downloaded.
Date Wed, 01 Oct 2008 12:19:20 GMT
Hello,

With ScriptAlias, you don't actually need Option (+)ExecCGI. You
simply need to allow access to that directory.

Also, make sure that the mod_cgi module is loaded, and you should be good to go.

Frank

On Wed, Oct 1, 2008 at 8:01 AM, Prathima Dandapani -X (pdandapa - HCL
at Cisco) <pdandapa@cisco.com> wrote:
> Hello All,
>
>             I have Apache 2.2.9 running.Perl script is not getting
> executed,but it is getting downloaded.Here is the configuration done for
> executing perl scripts.
>
>   ScriptAlias /cgi-bin/ "C:/PROGRA~1/CSCOpx/cgi-bin/"
> <Directory "C:/PROGRA~1/CSCOpx/cgi-bin/">
> AllowOverride None
> Options ExecCGI
> AddHandler cgi-script .pl
> ScriptInterpreterSource Registry-Strict
> </Directory>
>
> Please help me to resolve the issue.
>
> Thanks and Regards,
> Prathima.

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message