httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Eric Covener" <cove...@gmail.com>
Subject Re: [users@httpd] [users@http]
Date Fri, 17 Oct 2008 16:59:14 GMT
On Fri, Oct 17, 2008 at 12:45 PM, Charles Payne (Travel Channel)
<chuck.payne@travelchannel.com> wrote:
> Hi,
>
> I am not sure if this is the list to post this too. But I am having an issue
> with mod_rewrite. We are using Tomcat with Apache. We have a few site that
> we are doing rewrites too. But we are having an issue were if one of our
> vanity_rewrites are called on. An extra /domain rule is going added before
> the url for the rewrite. I have found the rule for the rewrite it is this...
>
> RewriteRule (.*)$ /domain$1 [PT,L]
>
> Now if I remove that rule the vanity works, but all links on the domain.com
> site don't. Again if that rule is try the vanity come out like this.
>
> http://www.domain.com/domain/vanity_url
>
> And we are getting a 404.


I don't fully follow what's going on, but you can short-circuit this
rule with a rewritecond:

RewriteCond %{REQUEST_URI} !vanity_url
RewriteRule (.*)$ /domain$1 [PT,L]


-- 
Eric Covener
covener@gmail.com

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message