httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Clayton Hicklin" <chick...@gmail.com>
Subject Re: [users@httpd] Pass-through LDAP authentication with Internet Explorer and Active Directory
Date Tue, 16 Sep 2008 18:07:57 GMT
On Tue, Sep 16, 2008 at 11:44 AM, Eric Covener <covener@gmail.com> wrote:

> On Tue, Sep 16, 2008 at 11:40 AM, Clayton Hicklin <chicklin@gmail.com>
> wrote:
> > As far as I can tell, the <domain>\ prefix is not stored anywhere inside
> the
> > user object, so there is no way to authenticate with the credentials that
> IE
> > provides.
> >
> > Has anybody got this working?  Is there some sort of workaround or hidden
> > parameter in the Apache LDAP modules that might fix this?  Thanks!
>
>
> Is there any other header set by IE when it does this automatic
> authentication? Is the password really sent along with it?
>
>
> --
> Eric Covener
> covener@gmail.com
>
> ---------------------------------------------------------------------
> The official User-To-User support forum of the Apache HTTP Server Project.
> See <URL:http://httpd.apache.org/userslist.html> for more info.
> To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
>   "   from the digest: users-digest-unsubscribe@httpd.apache.org
> For additional commands, e-mail: users-help@httpd.apache.org
>
>
I think these credentials are only sent to "trusted" sites as defined by
IE's security settings.  This is on an intranet, so it would be considered a
"trusted" site by default.

-- 
Clayton Hicklin
chicklin@gmail.com

Mime
View raw message