httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jorge Medina" <jmed...@e-dialog.com>
Subject RE: [users@httpd] How do I tell Apache where to find the APR and APR-utils?
Date Tue, 16 Sep 2008 20:49:06 GMT

I also ran 
# apachectl -V

And I get that other versions of the APR and APR-Util are getting
loaded, not the versions I compiled against.

LD_LIBRARY_PATH is set to
/opt/myapp/apache/lib:/opt/myapp/apr/lib:/opt/myapp/apr-util/lib:

Server version: Apache/2.2.8 (Unix)
Server built:   Sep 16 2008 11:25:55
Server's Module Magic Number: 20051115:11
Server loaded:  APR 1.2.7, APR-Util 1.2.7
Compiled using: APR 1.3.3, APR-Util 1.3.4

Heelp!!

Thank you.

-Jorge


-----Original Message-----
From: Jorge Medina [mailto:jmedina@e-dialog.com] 
Sent: Tuesday, September 16, 2008 4:16 PM
To: users@httpd.apache.org
Subject: [users@httpd] How do I tell Apache where to find the APR and
APR-utils?

Hi, 
   I am not sure this is the right forum for my question, but here it
is:

    		How do I tell Apache where to find the APR and APR-utils
libraries if the
    		libraries are in a different directory than that used in
the 'configure' step ?

   I am compiling Apache with the options 
       --prefix=/home/user/opt/myapp/apache
       --with-apr=/home/user/opt/myapp/apr
       --with-apr-util=/home/user/opt/myapp/apr-util
   
   I am creating a tar file with all my application (Apache, Tomcat and
couple of webapps) and deploying into a different machine, possibly in a
different path, usually /opt/myapp. The layout of my app ends up being
something like:

        /opt/myapp
		  |-- apache/
              |-- tomcat/
		  |-- apr/
		  \-- apr-util/

    When I try to start Apache, I get the error:
		 
httpd: Syntax error on line 70 of /opt/myapp/apache/conf/httpd.conf:
Cannot load /opt/myapp/apache/modules/mod_authn_dbd.so into server:
/opt/myapp/apache/modules/mod_authn_dbd.so: undefined symbol:
apr_dbd_get_name

    Before starting Apache, I already defined and exported the
environment variable:
	
LD_LIBRARY_PATH=/opt/myapp/apr/lib:/opt/myapp/apr-util/lib 
    But I keep getting the same error.

    I noticed that the APR and APR-util have a directory /lib/pkgconfig
with some files with the extension .pc
    I also modified those files to point to the right deployment
directory, but same error.

    How do I tell Apache where to find the APR and APR-utils libraries
if the
    libraries are in a different directory than that used in the
'configure' step ? 

    If this is not the right forum, could anybody suggest where could I
get an answer?
    Thanks.
	

-Jorge


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server
Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message