httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bill Tantzen" <tantz...@tc.umn.edu>
Subject [users@httpd] problems installing apache module
Date Wed, 03 Sep 2008 18:40:19 GMT
I am having major problems with what should be a simple task -- installing a
module as a DSO, specifically mod_fastcgi.  I have a have a hunch that the
problem is not with fastcgi, but instead with something I am doing wrong
while installing, and I'm hoping somebody can point me in a better
direction.

The error I see when I do a configtest is:
Syntax error on line 248 of /software/apache/conf/httpd.conf:
Cannot load /software/apache/libexec/mod_fastcgi.so into server:
/software/apache/libexec/mod_fastcgi.so: undefined symbol: OS_FcgiConnect

I have googled this error, and I got zip.

libfcgi.so is where the function is defined, and it is located in a
non-standard directory, /software/lib.  I tried passing these options to
apxs:

-Wl,-L/software/lib -W1,-R/software/lib

However, I'm still getting the same error from configtest.

This is apache 1.34 on RHEL 4.x (fastcgi 2.4.0)

Any ideas?

TIA,
Bill

Bill Tantzen
University of Minnesota Libraries
tantz001@tc.umn.edu
612-626-9949 (office)  612-325-1777 (cell) 
________________________________________________________________
Penny for your thoughts now, my boy Bill. -- Bruce Springsteen


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message