httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Xpert Advice <xpertadvice...@yahoo.com>
Subject Re: [users@httpd] Not Sure If This Is An Appache Problem Or a PHP problem
Date Fri, 26 Sep 2008 02:52:35 GMT
Ok I think we've stumbled onto the problem.  I think you may be right it may be a file permission
problem because I have moved this php.ini file everywhere.  I moved it to the apache2.2/bin
folder restarted the computer restarted apache didnt work.  I moved it to c:/windows folder
restarted computer restarted apache didnt work.....

when i load the test page every single time no matter which folder i put it into this is what
i get for paths

  
Configuration File (php.ini) Path  C:\Windows  
 
Loaded Configuration File  (none)  


So it keeps telling me there is no loaded config file when there is.... Now the file opens
in note pad and i dont believe its saved at a text time just all others.  So could that be
the problem? or do i need to change some kind of permission settings?
I already changed the path under advanced system settins and at first i added c:/php to the
path then i changed it as i moved the file around so im not sure where the permission problem
lies?
Tianja Samuel-George
President 



----- Original Message ----
From: Bradley Giesbrecht <brad@pixilla.com>
To: users@httpd.apache.org
Sent: Thursday, September 25, 2008 10:37:33 PM
Subject: Re: [users@httpd] Not Sure If This Is An Appache Problem Or a PHP problem

Having copies of php.ini laying around that are not being used is not your problem. 

Not sure what produced the output in your first email. Create a phpinfo.php file and put it
somewhere apache has access to it.
Make the contents of phpinfo.php the following:
<?php phpinfo(); ?>

Load the phpinfo.php served by apache in a browser..

Look for the path to php.ini in the screen that renders. If the path is a path that has a
php.ini try changing some configuration variable in that php.ini, restart apache and reload
phpinfo.php.

If you see the new value for your configuration variable you probably don't have php compiled
properly with the mysqli extension.

If you don't see the new value for your variable you might have a windows file permission
problem or something preventing the reading of your file.

I don't use Windows so this is the closest I can come to help.


//Brad


On Sep 25, 2008, at 2:52 PM, Xpert Advice wrote:

Thank You Soooo much for your quick response.  I've actually moved that php.ini file several
times I actually do currently have it in the C:\\Windows folder and I have restarded everything
since and for some reason its still not able to locate.  Now i never deleted the original
from C\\php\php.ini so could that be causing my problem?.  I've also tried putting the file
in C:\\windows\system32\php.ini  and that didnt work either. 

So originally it was in c:\php\php.ini but then first i tried copying it to c:\windows\php.ini
then restarted and everything then i tired putting it in C:\\windows\system32\php.ini and
restarted everything....again that didnt work.  Not sure if the problem is that I never
deleted the original i just copied it into the new locations....could that be it?
 Tianja Samuel-George
President 



----- Original Message ----
From: Stut <stuttle@gmail.com>
To: users@httpd.apache.org
Sent: Thursday, September 25, 2008 5:41:22 PM
Subject: Re: [users@httpd] Not Sure If This Is An Appache Problem Or a PHP problem

On 25 Sep 2008, at 22:18, Xpert Advice wrote:
> Fatal error: Call to undefined function mysqli_connect() in C: 
> \Apache2.2\htdocs\mysql_up.php on line 13
<snip>
>    2.  The php.ini file is currently located at c:/php/php.ini
<snip>
> Configuration File (php.ini) Path  C:\Windows

The above states that PHP is looking for php.ini in C:\Windows so it's  
not seeing your php.ini in c:/php. Move it to C:\Windows and restart  
Apache and it should see it properly (and indicate in the phpinfo  
output that it has been loaded).

-Stut

-- 
http://stut.net/

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache..org
  "  from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


      
Mime
View raw message