httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Prathima Dandapani -X \(pdandapa - HCL at Cisco\)" <pdand...@cisco.com>
Subject [users@httpd] Vitualhost not working in Apache 2.2.9
Date Mon, 15 Sep 2008 07:45:00 GMT
Hi All,
 
           We have upgraded Apache from 1.3.34 to 2.2.9 version.
           The virtualhost configuration used in 1.3.34 is not working in
2.2.9  and the configuration is as follows:
 
<IfDefine SSL>
Listen 443
Listen 1741
LoadModule ssl_module modules/mod_ssl.so
SSLMutex  default
SSLRandomSeed startup builtin
SSLRandomSeed connect builtin
SSLSessionCache dbm:C:/PROGRA~1/CSCOpx/MDC/Apache/logs/ssl_scache
SSLSessionCacheTimeout 600
SSLOptions +StdEnvVars +ExportCertData
SSLCipherSuite
ALL:!ADH:!EXPORT56:!EXPORT40:RC4+RSA:+HIGH:+MEDIUM:+LOW:+SSLv2:+EXP:+eNULL
<VirtualHost _default_:443>
SetEnvIf User-Agent ".*MSIE.*" nokeepalive ssl-unclean-shutdown
SSLEngine on
SSLCertificateFile conf/ssl/server.crt
SSLCertificateKeyFile conf/ssl/server.key
SSLCertificateChainFile conf/ssl/chain.cer
SSLCACertificatePath conf/ssl
# directive for session based authentication in ssl mode
<Location /> 
       Order deny,allow 
       Deny from all
       Allow from valid_session
</Location>  
</VirtualHost>
<VirtualHost _default_:1741>
<Location /> 
       Order deny,allow 
       Deny from all
       Allow from env=allow_http
</Location>  
</VirtualHost>
</IfDefine>
 
Apache is starting.but not able to serve pages.
The following error is seen in error.log 
  [Mon Sep 15 13:11:42 2008] [error] [client 127.0.0.1] File does not exist:
C:/Program Files/CSCOpx/htdocs/CSCOnm, referer: https://localhost/.
 
When I remove,Virtualhost directives,Am able to launch pages.
Please suggest some steps to make this work.
 
Regards,
Prathima
 

Mime
View raw message