httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Erling Wegger Linde" <erlin...@gmail.com>
Subject Re: [users@httpd] URL Encoding
Date Fri, 08 Aug 2008 06:12:45 GMT
Well, since Apache gets confused when itself decodes the URL - it
won't even pass it on decoded.. That's the biggest issue.

But furthermore as only one part of the URL is encoded.. e.g.
projects/{encoded} how should I make this generic? E.g. if(wasEncoded)
encode...

I'm now using Base64 encoding which works fine.

Thanks,
Erling

On Thu, Aug 7, 2008 at 10:26 PM, André Warnier <aw@ice-sa.com> wrote:
> Erling Wegger Linde wrote:
>>
>> However, Apache seem to decode this URL before it passes it forward to
>> Tomcat.
>
> I believe that this is what it's supposed to do.
> Can't you just re- URL-encode the URL before you let it be forwarded further
> ?
>
>
> ---------------------------------------------------------------------
> The official User-To-User support forum of the Apache HTTP Server Project.
> See <URL:http://httpd.apache.org/userslist.html> for more info.
> To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
>  "   from the digest: users-digest-unsubscribe@httpd.apache.org
> For additional commands, e-mail: users-help@httpd.apache.org
>
>

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message