httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From pthys...@intec.ugent.be
Subject [users@httpd] Apache 2.0.52 / mod_jk / firewall / jboss weirdness
Date Thu, 07 Aug 2008 13:41:27 GMT
Hello everyone (my previous message was sent prematurely...),

I'm trying to figure out some weirdness in a fairly large web environment.

We're running a web environment using RHEL 4, Apache 2.0.52 with Worker
MPM, mod_jk 1.2.20 and jboss/tomcat application servers.
There's a firewall between our web and application servers, and I have
read about mod_jk and firewalls (i.e. socket_keepalive = 1).

A weird thing I see is that sometimes, the apache server status page
displays requests/threads in the "W" (sending reply) state up to Apache
timeout, while the Jboss Jk status shows no threads for that client in the
"Service" state.

In fact, most of the "busy" threads are reported to be in the "Keepalive"
state - I presume due to the use of  socket_keepalive = 1 in
workers.properties.

This means my problem kind of resembles the one described at
http://blogs.warwick.ac.uk/chrismay/entry/wierd_apache_mod/, where Apache
threads get stuck in the "W" state instead of being closed (as to be
expected) - as if client-apache and apache/mod_jk - backend appserver
connections are not "detached".

I'm wondering what can cause this behaviour, as my worker.properties has
the following:

socket_timeout=60
connect_timeout=30000
prepost_timeout=30000
reply_timeout=120000
socket_keepalive=1
connection_pool_timeout=600

When socket_keepalive=1, how long does a connection exist between mod_jk
and the application server? How can I control it?

Do I need to use cache_Size and cache_timeout in workers.properties? I
don't quite get their explanation - but cache_timeout does talk about
reducing the number of threads on the backend.

It seems the poster pointed to by the link I gave solved his problem by
implementing the mod_jk firewall howto in the end (i.e. set
socket_keepalive to 1) - but I am still having similar issues it seems.
Does this ring a bell with anyone?


Kind regards,
Pieter

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message