httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ivan Lezhnjov Jr." <ivan.lezhnjov...@gmail.com>
Subject [users@httpd] config.layout not working (?) with old and latest stable but legacy apache
Date Fri, 29 Aug 2008 14:36:19 GMT
Hello there!

I'm trying to build httpd from source code using custom layout.config but 
whenever I run ./configure script it returns the following error message:

ilj@xerxes:~/pkg-area/src/httpd-2.2.8 % ./configure --enable-layout=Slackware22
checking for chosen layout... Slackware22
checking for working mkdir -p... yes
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking target system type... i686-pc-linux-gnu

Configuring Apache Portable Runtime library ...

checking for APR... yes
  setting CC to "i486-slackware-linux-gcc"
  setting CPP to "i486-slackware-linux-gcc -E"
  setting CFLAGS to "  -pthread"
  setting CPPFLAGS 
to " -DLINUX=2 -D_REENTRANT -D_GNU_SOURCE -D_LARGEFILE64_SOURCE"
  setting LDFLAGS to " "

Configuring Apache Portable Runtime Utility library...

checking for APR-util... yes
checking for gcc... i486-slackware-linux-gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether i486-slackware-linux-gcc accepts -g... yes
checking for i486-slackware-linux-gcc option to accept ISO C89... none needed
checking how to run the C preprocessor... i486-slackware-linux-gcc -E
configure: Configuring PCRE regular expression library
configuring package in srclib/pcre now
configure: error: expected an absolute directory name for --bindir: NONE/bin
configure failed for srclib/pcre


config.layout looks like this:

ilj@xerxes:~/pkg-area/src/httpd-2.2.8 % cat config.layout
<Layout Slackware22>
    prefix:        /usr
    exec_prefix:   /usr
    bindir:        /usr/bin
    sbindir:       /usr/sbin
    libdir:        /usr/lib
    libexecdir:    /usr/libexec
    mandir:        /usr/share/man
    sysconfdir:    /etc/httpd
    datadir:       /var/www
    installbuilddir: /var/www/build
    errordir:      /var/www/error
    iconsdir:      /var/www/icons
    htdocsdir:     /var/www/htdocs
    manualdir:     /var/www/manual
    cgidir:        /var/www/cgi-bin
    includedir:    /usr/include/apache2
    localstatedir: /var
    runtimedir:    /var/run
    logfiledir:    /var/log
    proxycachedir: /var/cache/apache2/proxy
</Layout>

I tried apache versions 2.2.8, 2.2.9, 2.0.63 and each time configure returns 
exactly the same error message.

1.3.41 accepts --with-layout=LAYOUT option, though.

I'm relatively new to building apache from source code so I believe there's 
just a catch I don't know about (and can't actually figure out on my own 
using Google).

I attempt to build httpd on Slackware 11 system if that matters.

-- 

  Ivan Lezhnjov Jr.

  Europe, Ukraine, Simferopol

  Running
  Source Mage GNU/Linux, kernel version 2.6.24 build #5

+----------------------------------------------------------------------+

           Key ID 0x5811D90C
  Key Fingerprint 2A52 5C8C 38BE C04F D8DE  A169 19E2 E49A 5811 D90C
          Use GPG Exercise Your Right To Privacy 

Mime
View raw message