httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dan_Mit...@YMP.GOV
Subject [users@httpd] Problems building httpd 2.2.9 on Sun Solaris 9 SPARC
Date Fri, 11 Jul 2008 14:56:44 GMT
At several places in the 'configure' process, I am getting a WARNING about 
'Unrecognized options'.  I have used all of these options before, at least 
on the 2.2.2, 2.2.3, 2.2.4 & 2.2.6 versions.  The help says they are all 
valid.  Other then these WARNING, configure completes with no errors (see 
text below).  'make' seems to run OK, with no errors (see below), but 
'make install' dies with:

/bin/bash: -c: line 1: syntax error near unexpected token `;'
/bin/bash: -c: line 1: `for m in ; do /bin/bash 
/usr/local/opt/httpd-2.2.9/srclib/apr/libtool  --silent --mode=install 
build/install.sh -c -m 755 $m /usr/local/apache-2.2.9/lib/apr-util-1; 
done'

this is in the srclib/apr-util/Makefile.  It looks like the APU_MODULES is 
not getting set propery:

#
# Top-level Makefile for APRUTIL
#
CPP = gcc -E

# gets substituted into some targets
APRUTIL_MAJOR_VERSION=1
APRUTIL_DOTTED_VERSION=1.3.0

srcdir = .


INCLUDES = -I/usr/local/opt/httpd-2.2.9/srclib/apr-util/include 
-I/usr/local/opt/httpd-2.2.9/srclib/apr-util/include/private 
-I/usr/local/opt
/httpd-2.2.9/srclib/apr/include 
-I/usr/local/opt/httpd-2.2.9/srclib/apr-util/xml/expat/lib
APRUTIL_LDFLAGS =
APRUTIL_LIBS = 
/usr/local/opt/httpd-2.2.9/srclib/apr-util/xml/expat/lib/libexpat.la 
-liconv /usr/local/opt/httpd-2.2.9/srclib/apr/libapr-1.la
-luuid -lsendfile -lrt -lsocket -lnsl -lpthread -ldl

TARGET_LIB = libaprutil-${APRUTIL_MAJOR_VERSION}.la
INSTALL_SUBDIRS =  xml/expat
EXTRA_SOURCE_DIRS =  xml/expat
APRUTIL_PCFILE = apr-util-$(APRUTIL_MAJOR_VERSION).pc
APU_CONFIG = apu-$(APRUTIL_MAJOR_VERSION)-config
INSTALL = build/install.sh -c
INSTALL_DATA = ${INSTALL} -m 644

APU_MODULES =
LINK_MODULE = $(LIBTOOL) $(LTFLAGS) --mode=link $(CC) $(LT_LDFLAGS) 
$(ALL_CFLAGS) $(ALL_LDFLAGS) $(APRUTIL_LDFLAGS) -release $(APRUTIL_MAJOR_V
ERSION) -module -rpath $(APU_DSO_LIBDIR)
APU_DSO_LIBDIR = ${libdir}/apr-util-1

LT_VERSION = -version-info 3:0:3

EXTRA_OBJECTS =
        .
        .
        .
install-modules-yes: $(APU_MODULES)
        $(APR_MKDIR) $(DESTDIR)$(APU_DSO_LIBDIR)
        @for m in $(APU_MODULES); do $(LIBTOOL) $(LT_LTFLAGS) $(LTFLAGS) 
--mode=install $(INSTALL) -m 755 $$m $(DESTDIR)$(APU_DSO_LIBDIR); done
        .
        .
        .

This is on a Sun Solaris 9 Sparc machine.  Any help would be greatly 
appreciated :)

/usr/local/opt/httpd-2.2.9>./configure --prefix=/usr/local/apache-2.2.9 
--with-ssl=/usr/local/ssl --with-z=/usr/local/lib --enable-ssl 
--enable-cache --enable-disk-cache --enable-mem-cache --enable-autoindex 
--enable-mods-shared="rewrite ssl dav dav-fs proxy"
checking for chosen layout... Apache
checking for working mkdir -p... yes
checking build system type... sparc-sun-solaris2.9
checking host system type... sparc-sun-solaris2.9
checking target system type... sparc-sun-solaris2.9

Configuring Apache Portable Runtime library ...

checking for APR... reconfig
configuring package in srclib/apr now
configure: WARNING: Unrecognized options: --with-ssl, --with-z, 
--enable-ssl, --enable-cache, --enable-disk-cache, --enable-mem-cache, 
--enable-autoindex, --enable-mods-shared
checking build system type... sparc-sun-solaris2.9
checking host system type... sparc-sun-solaris2.9
checking target system type... sparc-sun-solaris2.9
        .
        .
        .
config.status: executing default commands
config.status: include/apr.h is unchanged
config.status: include/arch/unix/apr_private.h is unchanged
configure: WARNING: Unrecognized options: --with-ssl, --with-z, 
--enable-ssl, --enable-cache, --enable-disk-cache, --enable-mem-cache, 
--enable-autoindex, --enable-mods-shared
srclib/apr configured properly
  setting CC to "gcc"
  setting CPP to "gcc -E"
  setting CFLAGS to " -g -O2 -pthreads"
  setting CPPFLAGS to " -DSOLARIS2=9 -D_POSIX_PTHREAD_SEMANTICS 
-D_REENTRANT -D_LARGEFILE64_SOURCE"
  setting LDFLAGS to " "

Configuring Apache Portable Runtime Utility library...

checking for APR-util... reconfig
configuring package in srclib/apr-util now
configure: WARNING: Unrecognized options: --with-ssl, --with-z, 
--enable-ssl, --enable-cache, --enable-disk-cache, --enable-mem-cache, 
--enable-autoindex, --enable-mods-shared
checking build system type... sparc-sun-solaris2.9
checking host system type... sparc-sun-solaris2.9
checking target system type... sparc-sun-solaris2.9
        .
        .
        .
checking Expat 1.95.x... no
checking old Debian-packaged expat... no
checking old FreeBSD-packaged expat... no
checking Expat 1.0/1.1... no
  setting LDFLAGS to "-L/usr/local/lib"
  adding "-I/usr/local/include" to CPPFLAGS
checking Expat 1.95.x in /usr/local... no
  nulling LDFLAGS
  removed "-I/usr/local/include" from CPPFLAGS
configuring package in xml/expat now
configure: WARNING: Unrecognized options: --with-ssl, --with-z, 
--enable-ssl, --enable-cache, --enable-disk-cache, --enable-mem-cache, 
--enable-autoindex, --enable-mods-shared, --with-apr
checking build system type... sparc-sun-solaris2.9
checking host system type... sparc-sun-solaris2.9
checking target system type... sparc-sun-solaris2.9
checking for gcc... gcc
        .
        .
        .
configure: creating ./config.status
config.status: creating Makefile
config.status: WARNING:  'Makefile.in' seems to ignore the --datarootdir 
setting
config.status: creating lib/Makefile
config.status: WARNING:  'lib/Makefile.in' seems to ignore the 
--datarootdir setting
config.status: creating lib/expat.h
config.status: creating config.h
config.status: config.h is unchanged
configure: WARNING: Unrecognized options: --with-ssl, --with-z, 
--enable-ssl, --enable-cache, --enable-disk-cache, --enable-mem-cache, 
--enable-autoindex, --enable-mods-shared, --with-apr
xml/expat configured properly
  setting APRUTIL_INCLUDES to 
"-I/usr/local/opt/httpd-2.2.9/srclib/apr-util/xml/expat/lib"
  setting LDFLAGS to 
"-L/usr/local/opt/httpd-2.2.9/srclib/apr-util/xml/expat/lib"
  setting APRUTIL_EXPORT_LIBS to 
"/usr/local/opt/httpd-2.2.9/srclib/apr-util/xml/expat/lib/libexpat.la"
  setting APRUTIL_LIBS to 
"/usr/local/opt/httpd-2.2.9/srclib/apr-util/xml/expat/lib/libexpat.la"
        .
        .
        .
config.status: creating include/private/apu_config.h
config.status: include/private/apu_config.h is unchanged
config.status: executing default commands
configure: WARNING: Unrecognized options: --with-ssl, --with-z, 
--enable-ssl, --enable-cache, --enable-disk-cache, --enable-mem-cache, 
--enable-autoindex, --enable-mods-shared
srclib/apr-util configured properly
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking how to run the C preprocessor... gcc -E
configure: Configuring PCRE regular expression library
configuring package in srclib/pcre now
configure: WARNING: Unrecognized options: --with-ssl, --with-z, 
--enable-ssl, --enable-cache, --enable-disk-cache, --enable-mem-cache, 
--enable-autoindex, --enable-mods-shared
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
        .
        .
        .
config.status: creating pcre-config
config.status: creating config.h
config.status: config.h is unchanged
config.status: executing default commands
configure: WARNING: Unrecognized options: --with-ssl, --with-z, 
--enable-ssl, --enable-cache, --enable-disk-cache, --enable-mem-cache, 
--enable-autoindex, --enable-mods-shared
srclib/pcre configured properly
  setting AP_LIBS to "/usr/local/opt/httpd-2.2.9/srclib/pcre/libpcre.la"
  setting INCLUDES to "-I$(top_builddir)/srclib/pcre"
        .
        .
        .
config.status: creating include/ap_config_auto.h
config.status: include/ap_config_auto.h is unchanged
config.status: executing default commands
/usr/local/opt/httpd-2.2.9>

====================================================================================================

/usr/local/opt/httpd-2.2.9>make
Making all in srclib
make[1]: Entering directory `/usr/local/opt/httpd-2.2.9/srclib'
Making all in apr
make[2]: Entering directory `/usr/local/opt/httpd-2.2.9/srclib/apr'
make[3]: Entering directory `/usr/local/opt/httpd-2.2.9/srclib/apr'
        .
        .
        .
make[4]: Leaving directory `/usr/local/opt/httpd-2.2.9/modules/mappers'
make[3]: Leaving directory `/usr/local/opt/httpd-2.2.9/modules/mappers'
make[2]: Leaving directory `/usr/local/opt/httpd-2.2.9/modules'
make[2]: Entering directory `/usr/local/opt/httpd-2.2.9/support'
make[2]: Leaving directory `/usr/local/opt/httpd-2.2.9/support'

make[1]: Leaving directory `/usr/local/opt/httpd-2.2.9'
/usr/local/opt/httpd-2.2.9>

====================================================================================================

/usr/local/opt/httpd-2.2.9>make install
Making install in srclib
make[1]: Entering directory `/usr/local/opt/httpd-2.2.9/srclib'
Making install in apr
make[2]: Entering directory `/usr/local/opt/httpd-2.2.9/srclib/apr'
make[3]: Entering directory `/usr/local/opt/httpd-2.2.9/srclib/apr'
make[3]: Nothing to be done for `local-all'.
make[3]: Leaving directory `/usr/local/opt/httpd-2.2.9/srclib/apr'
/usr/local/opt/httpd-2.2.9/srclib/apr/build/mkdir.sh 
/usr/local/apache-2.2.9/lib /usr/local/apache-2.2.9/bin 
/usr/local/apache-2.2.9/build \
             /usr/local/apache-2.2.9/lib/pkgconfig 
/usr/local/apache-2.2.9/include
build/install.sh -c -m 644 
/usr/local/opt/httpd-2.2.9/srclib/apr/include/apr.h 
/usr/local/apache-2.2.9/include
for f in /usr/local/opt/httpd-2.2.9/srclib/apr/include/apr_*.h; do \
    build/install.sh -c -m 644 ${f} /usr/local/apache-2.2.9/include; \
done
/bin/bash /usr/local/opt/httpd-2.2.9/srclib/apr/libtool --mode=install 
build/install.sh -c -m 755 libapr-1.la /usr/local/apache-2.2.9/lib
build/install.sh -c -m 755 .libs/libapr-1.so.0.3.0 
/usr/local/apache-2.2.9/lib/libapr-1.so.0.3.0
(cd /usr/local/apache-2.2.9/lib && { ln -s -f libapr-1.so.0.3.0 
libapr-1.so.0 || { rm -f libapr-1.so.0 && ln -s libapr-1.so.0.3.0 
libapr-1.so.0; }; })
ln: cannot create libapr-1.so.0: File exists
(cd /usr/local/apache-2.2.9/lib && { ln -s -f libapr-1.so.0.3.0 
libapr-1.so || { rm -f libapr-1.so && ln -s libapr-1.so.0.3.0 libapr-1.so; 
}; })
ln: cannot create libapr-1.so: File exists
chmod +x /usr/local/apache-2.2.9/lib/libapr-1.so.0.3.0
build/install.sh -c -m 755 .libs/libapr-1.lai 
/usr/local/apache-2.2.9/lib/libapr-1.la
build/install.sh -c -m 755 .libs/libapr-1.a 
/usr/local/apache-2.2.9/lib/libapr-1.a
chmod 644 /usr/local/apache-2.2.9/lib/libapr-1.a
ranlib /usr/local/apache-2.2.9/lib/libapr-1.a
----------------------------------------------------------------------
Libraries have been installed in:
   /usr/local/apache-2.2.9/lib

If you ever happen to want to link against installed libraries
in a given directory, LIBDIR, you must either use libtool, and
specify the full pathname of the library, or use the `-LLIBDIR'
flag during linking and do at least one of the following:
   - add LIBDIR to the `LD_LIBRARY_PATH' environment variable
     during execution
   - use the `-RLIBDIR' linker flag

See any operating system documentation about shared libraries for
more information, such as the ld(1) and ld.so(8) manual pages.
----------------------------------------------------------------------
build/install.sh -c -m 644 apr.exp /usr/local/apache-2.2.9/lib/apr.exp
build/install.sh -c -m 644 apr.pc 
/usr/local/apache-2.2.9/lib/pkgconfig/apr-1.pc
for f in libtool shlibtool; do \
    if test -f ${f}; then build/install.sh -c -m 755 ${f} 
/usr/local/apache-2.2.9/build; fi; \
done
build/install.sh -c -m 755 
/usr/local/opt/httpd-2.2.9/srclib/apr/build/mkdir.sh 
/usr/local/apache-2.2.9/build
for f in make_exports.awk make_var_export.awk; do \
    build/install.sh -c -m 644 
/usr/local/opt/httpd-2.2.9/srclib/apr/build/${f} 
/usr/local/apache-2.2.9/build; \
done
build/install.sh -c -m 644 build/apr_rules.out 
/usr/local/apache-2.2.9/build/apr_rules.mk
build/install.sh -c -m 755 apr-config.out 
/usr/local/apache-2.2.9/bin/apr-1-config
make[2]: Leaving directory `/usr/local/opt/httpd-2.2.9/srclib/apr'
Making install in apr-util
make[2]: Entering directory `/usr/local/opt/httpd-2.2.9/srclib/apr-util'
/usr/local/opt/httpd-2.2.9/srclib/apr/build/mkdir.sh 
/usr/local/apache-2.2.9/lib/apr-util-1
/bin/bash: -c: line 1: syntax error near unexpected token `;'
/bin/bash: -c: line 1: `for m in ; do /bin/bash 
/usr/local/opt/httpd-2.2.9/srclib/apr/libtool  --silent --mode=install 
build/install.sh -c -m 755 $m /usr/local/apache-2.2.9/lib/apr-util-1; 
done'
make[2]: *** [install-modules-yes] Error 2
make[2]: Leaving directory `/usr/local/opt/httpd-2.2.9/srclib/apr-util'
make[1]: *** [install-recursive] Error 1
make[1]: Leaving directory `/usr/local/opt/httpd-2.2.9/srclib'
make: *** [install-recursive] Error 1
/usr/local/opt/httpd-2.2.9>


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message