httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nino Saturnino Martinez Vazquez Wael <nino.marti...@jayway.dk>
Subject Re: [users@httpd] mod proxy & DSO errors(403 forbidden)?
Date Tue, 22 Jul 2008 18:48:59 GMT
I posted my full vhost config, if I hit tomcat directly everything 
works, but I agree  there are something fishy regarding "sub" sites, like
 

/static/f5ffa9029c78c03cdf54c3b0d4999417-thumb.jpg

I've also tried adding this : ProxyPass /static balancer://cluster/static

It does not work. Another thing though are that if I remove the loadbalancer configuration
I get an 502 (bad gateway or proxy)

error.log
[Tue Jul 22 20:43:01 2008] [error] [client client] proxy: DNS lookup failure for: beta-1.net:8080css
returned by /css/images/pages-forward.gif, referer: http://apache2server.com/

notice this part: "beta-1.net:8080css" , thats not right. So whats wrong with this? I have
something similar working another place..


Vhost config:

<VirtualHost *:80>
ProxyPreserveHost on
LoadModule proxy_module /usr/lib/apache2/modules/mod_proxy.so

LoadModule proxy_balancer_module /usr/lib/apache2/modules/mod_proxy_balancer.so
LoadModule proxy_connect_module /usr/lib/apache2/modules/mod_proxy_connect.so
LoadModule proxy_ftp_module /usr/lib/apache2/modules/mod_proxy_ftp.so
LoadModule proxy_html_module /usr/lib/apache2/modules/mod_proxy_html.so
LoadModule proxy_http_module /usr/lib/apache2/modules/mod_proxy_http.so

        ProxyRequests off
        ServerName servername.net
        ServerAlias *

        ProxyPass / http://beta-1.net:8080
        ProxyPass /js http://beta-1.net:8080/js
	ProxyPass /css http://beta-1.net:8080/css

        <Proxy *>
                Order Deny,Allow
                 Allow from all
        </Proxy>


        <Location /balancer-manager>
                SetHandler balancer-manager                      
                Order deny,allow
                Allow from all
        </Location>

</VirtualHost>











Eric Covener wrote:
> On Tue, Jul 22, 2008 at 9:32 AM, Frank Gingras
> <francois.gingras@gmail.com> wrote:
>   
>> Nino,
>>
>> Your error definitely indicates that it's not loaded. Let's run apache2ctl /
>> apache2 -M, and see what it says.
>>
>>     
>>> No protocol handler was valid for the URL /static/f5ffa9029c78c03cdf54c3b0d4999417-thumb.jpg.
>>>       
>
> Wouldn't that URL normally have a protocol at the front of it? Are you
> proxying "to" something that isn't a full URL?
>
>
>   

-- 
-Wicket for love

Nino Martinez Wael
Java Specialist @ Jayway DK
http://www.jayway.dk
+45 2936 7684


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message