httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From André Warnier ...@ice-sa.com>
Subject Re: [users@httpd] Problem while clustering Jboss
Date Wed, 09 Jul 2008 23:26:42 GMT
Ch Praveena wrote:
> *
> Hi all,
> *
>               I am trying to cluster 2 jboss 4.2.2.GA instances and found
> this in the httpd server logs. And so, I could not cluster the instances
> properly. Please let me know where exactly I might have done the error?*
> 

> [Wed Jul 09 18:10:27 2008][6637:3086218944] [info]
> jk_open_socket::jk_connect.c (566): connect to 10.20.220.135:8009 failed
> (errno=111)
> [Wed Jul 09 18:10:27 2008][6637:3086218944] [info]
> ajp_connect_to_endpoint::jk_ajp_common.c (869): Failed opening socket to (
> 10.20.220.135:8009) (errno=111)
> [Wed Jul 09 18:10:27 2008][6637:3086218944] [error]
> ajp_send_request::jk_ajp_common.c (1359): (node2) connecting to backend
> failed. Tomcat is probably not started or is listening on the wrong port
> (errno=111)

On the face of it, from the above it looks as if your "node 2" is just 
not listening either on the specified IP address (10.20.220.135) or on 
the specified port (8009).  Are you sure node 2 has a <Connector 
port="8009" ..>, and really has the IP address 10.20.220.135 ?
You can test this with
telnet 10.20.220.135 8009
it will give you garbage probably, but it the connection is refused or 
the host not found, it should tell you something.


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message