httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Matt Funk <matze...@gmx.net>
Subject [users@httpd] php and apache
Date Wed, 09 Jul 2008 22:49:14 GMT
Hi,

i hope i am posting to the right list. 

Just upfront: I am by no means an expert with apache but i have never really 
had any issues setting up a web server. 

Anyway, I am running apache/2.2.9 on a debian etch box. My setup used to work 
but after a friend did a debian upgrade something seems to have gone wrong.

There seem to be several issues (one is that the virtual host doesn't seem to 
work anymore(even though it is enabled). I.e. it only picks up the index.html 
in the root directory). However the first issue is that the php support 
doesn't seem to work anymore. 

When i apachectl -M it tells me that the php5_module (shared) is loaded.
I can restart reload the server without any problem. I didn't see anything in 
the error.log either.  
 
Here is the modified index.html that the server looks at:
<html>
 <head>
  <title>Index.html: PHP Test</title>
 </head>
 <body>
 PHP test 2<br />
 <?php echo '<p>Hello World</p>'; ?>
 </body>
</html>

It does not interpret the php correctly. Like i said, i am not an expert, so 
hopefully there is someone who can point me in the right direction?

thanks
matt

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message