httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Wulf Kaiser <wulf.kai...@mpimf-heidelberg.mpg.de>
Subject [users@httpd] Update: AW: [users@httpd] Strange compile / build problem: Apache 2.2.9 under Solaris 10 SPARC
Date Thu, 10 Jul 2008 08:47:21 GMT
Hi Igor, Hi all others,

At first: thanks for your help so far.

I did everything again, checking every step double twice

-- env flags

bash-3.00#
export CC="/usr/sfw/bin/gcc"
export LDFLAGS="-R/usr/sfw/lib/sparcv9 -L/usr/sfw/lib/sparcv9 -R/usr/lib
-L/usr/lib -R/usr/sfw/lib -L/usr/sfw/lib -R/opt/csw/lib -L/opt/csw/lib
-R/opt/csw/bdb4/lib -L/opt/csw/bdb4/lib -R/lib -L/lib -R/etc/lib -L/etc/lib"
\
export CPPFLAGS="-I/usr/include -I/usr/sfw/include -I/opt/csw/include
-I/opt/csw/bdb4/include" \
export CFLAGS="-I/usr/include -I/usr/sfw/include -I/opt/csw/include
-I/opt/csw/bdb4/include" \
export
PATH=/usr/bin:/usr/sfw/bin:/opt/csw/bin:/usr/sbin:/usr/ccs/bin:/opt/csw/bdb4
/bin \
export
LD_LIBRARY_PATH=/usr/lib:/usr/sfw/lib:/opt/csw/lib:/opt/csw/bdb4/lib:/lib:/e
tc/lib \
export
LD_RUN_PATH=/usr/bin:/usr/sfw/bin:/opt/csw/bin:/usr/sbin:/usr/ccs/bin:/opt/c
sw/bdb4/bin

-- configure

./configure --prefix=/usr/local/apache-2.2.9 --with-included-apr
--with-mpm=prefork --enable-nonportable-atomics=yes --with-ssl
--enable-ssl=shared --with-ldap --enable-ldap=shared
--enable-authnz-ldap=shared --enable-dav --enable-dav-fs
--enable-auth-basic=shared --enable-auth-digest=shared
--enable-authn-alias=shared --enable-authn-file=shared
--enable-authz-owner=shared --enable-cache=shared --enable-file-cache=shared
--enable-mem-cache=shared --enable-disk-cache=shared --enable-proxy=shared
--enable-proxy-connect=shared --enable-proxy-ftp=shared
--enable-proxy-http=shared --enable-proxy-ajp=shared
--enable-proxy-balancer=shared --enable-cgi=shared --enable-rewrite=shared
--enable-version=shared --enable-vhost-alias=shared --enable-so
--enable-static-rotatelogs 


but i still cannot build httpd-2.2.9 under Solaris 10 SPARC. builconf and
configure ran fine, without errors or warnings, and then came make:

*** Error code 1
*** Error code 1
The following command caused the error:
otarget=`echo all-recursive | sed s/-recursive//`; \
list='xml dbd dbm encoding hooks buckets misc crypto uri strmatch memcache
dbm/sdbm ldap xlate '; \
for i in $list; do \
    if test -f "$i/Makefile"; then \
        target="$otarget"; \
        echo "Making $target in $i"; \
        if test "$i" = "."; then \
            made_local=yes; \
            target="local-$target"; \
        fi; \
        (cd $i && make $target) || exit 1; \
    fi; \
done; \
        if test "$otarget" = "all" && test -z "libaprutil-1.la aprutil.exp
apu-config.out ldap/apr_ldap.la"; then \
    made_local=yes; \
fi; \
if test "$made_local" != "yes"; then \
    make "local-$otarget" || exit 1; \
fi
*** Error code 1
The following command caused the error:
otarget=`echo all-recursive|sed s/-recursive//`; \
list=' apr apr-util pcre '; \
for i in $list; do \
    if test -d "$i"; then \
        target="$otarget"; \
        echo "Making $target in $i"; \
        if test "$i" = "."; then \
                made_local=yes; \
                target="local-$target"; \
        fi; \
        (cd $i && make $target) || exit 1; \
    fi; \
done; \
if test "$otarget" = "all" && test -z ''; then \
    made_local=yes; \
fi; \
if test "$made_local" != "yes"; then \
    make "local-$otarget" || exit 1; \
fi
*** Error code 1
The following command caused the error:
otarget=`echo all-recursive|sed s/-recursive//`; \
list='  srclib os server modules support'; \
for i in $list; do \
    if test -d "$i"; then \
        target="$otarget"; \
        echo "Making $target in $i"; \
        if test "$i" = "."; then \
                made_local=yes; \
                target="local-$target"; \
        fi; \
        (cd $i && make $target) || exit 1; \
    fi; \
done; \
if test "$otarget" = "all" && test -z 'httpd shared-build '; then \
    made_local=yes; \
fi; \
if test "$made_local" != "yes"; then \
    make "local-$otarget" || exit 1; \
Fi



Liebe Grüsse, 

Wulf Kaiser
___________________________ 

IT Services - Web & Database Development
Webmaster www.mpimf-heidelberg.mpg.de

Max-Planck-Institut für medizinische Forschung
Jahnstrasse 29 - 69120 Heidelberg
Fon +49 6221 486560    Fax +49 6221 486561

SHA1 Fingerprint:
6a a7 67 d6 e0 21 d1 59 d1 73 20 fb e8 b4 d9 51 ac aa 6d 17
 

> -----Ursprüngliche Nachricht-----
> Von: Igor Galic [mailto:i.galic@brainsware.org] 
> Gesendet: Dienstag, 8. Juli 2008 18:51
> An: Wulf Kaiser
> Cc: users@httpd.apache.org
> Betreff: Re: [users@httpd] Strange compile / build problem: 
> Apache 2.2.9 under Solaris 10 SPARC
> 
> 
> Hi Wulf,
> 
> There's an issue with 2.2.9's configure
> https://issues.apache.org/bugzilla/show_bug.cgi?id=45221#c6
> 
> Running ./buildconf should solve it.
> 
> > The Environment Flags:
> >
> > bash-3.00#
> > export CC="/usr/sfw/bin/gcc"
> > export LDFLAGS="-R/usr/sfw/lib/sparcv9 -L/usr/sfw/lib/sparcv9 
> > -R/usr/lib -L/usr/lib -R/usr/sfw/lib -L/usr/sfw/lib -R/opt/csw/lib 
> > -L/opt/csw/lib -R/usr/local/ssl/lib -L/usr/local/ssl/lib 
> > -R/opt/csw/bdb4/lib -L/opt/csw/bdb4/lib -R/lib -L/lib -R/etc/lib 
> > -L/etc/lib" \
> 
> I suggest you use -lssl_extra -lcrypto_extra, provided by 
> SUNWcry for higher level encryption.
> 
> > ./configure --prefix=/usr/local/apache-2.2.9 --with-included-apr 
> > --with-mpm=prefork --with-ssl --enable-ssl=shared --with-ldap 
> > --enable-ldap=shared --enable-auth-basic=shared 
> > --enable-auth-digest=shared --enable-authn-alias=shared 
> > --enable-authnz-ldap=shared --enable-authn-file=shared  
> > --enable-authz-owner=shared  --enable-cache=shared 
> > --enable-file-cache=shared --enable-mem-cache=shared 
> > --enable-disk-cache=shared --enable-proxy=shared 
> > --enable-proxy-connect=shared --enable-proxy-ftp=shared 
> > --enable-proxy-http=shared --enable-proxy-ajp=shared 
> > --enable-proxy-balancer=shared --enable-cgi=shared 
> > --enable-rewrite=shared --enable-version=shared 
> > --enable-vhost-alias=shared --enable-so --enable-dav 
> --enable-dav-fs 
> > --enable-cgi --enable-static-rotatelogs > 
> > /usr/local/src/apache/configure_229_full.out && make > 
> > /usr/local/src/apache/make_229_full.out && make install > 
> > /usr/local/src/apache/make_install_229_full.out
> As you're on Solaris, you might want to also take a look at:
> 
> http://httpd.apache.org/docs/2.2/misc/perf-tuning.html#compiletime
> 
> > Best,
> >
> > Wulf Kaiser
> So long,
> Igor
> 

Mime
View raw message