httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From marc.sc...@jpmchase.com
Subject Re: [users@httpd] "The <apache version> service on Local Computer started and stopped"
Date Fri, 06 Jun 2008 19:05:16 GMT

found my problem.  Unknown to me (as this is a work computer) I had
Aventail installed on my machine.  I saw this error can sometimes occur
with Aventail installed.  When I tried to uninstall it, I had all kinds of
issues.  After I had my machine reimaged by our support staff (without the
addition of Aventail), I was able to get Apache working.  Thanks for the
help!

Marc



                                                                           
             André Warnier                                                 
             <aw@ice-sa.com>                                               
                                                                        To 
             06/03/2008 11:28          users@httpd.apache.org              
             AM                                                         cc 
                                                                           
                                                                   Subject 
             Please respond to         Re: [users@httpd] "The <apache      
             users@httpd.apach         version> service on Local Computer  
                   e.org               started and stopped"                
                                                                           
                                                                           
                                                                           
                                                                           
                                                                           
                                                                           





marc.scott@jpmchase.com wrote:
> Thanks for the suggestions Andre, but it's still a no-go.  It loaded 20
> modules, the last of which was setenvif_module, but then returned a
system
> prompt.  No errors or anything.  I attempted to view the default Apache
> page (to see if the service was up), as well as looked in the service
> viewer, and nothing.
>
> And I am a local admin on my machine, so that shouldn't have effected the
> netstat output.
>
> Any other suggestions?
>


I'm not a real Apache guru, I just work here.
This being said, it sounds like it stops dead in it's tracks, but after
loading the modules.  The little I know would seem to indicate that it
would stop just at the moment when the main startup instance tries to
"fork" (or under Windows probably start threads) to start handling
requests.
Maybe you could try removing some of the modules, starting at the end
(mod_setenvif) ?
By the way, is that the last module mentioned to be loaded in your
configuration ?

And also, how much memory do you have on that station (real and virtual) ?

André


P.S.
I am loading the following (496 MB RAM, virtual set to 2048 MB):
LoadModule actions_module modules/mod_actions.so
LoadModule alias_module modules/mod_alias.so
LoadModule asis_module modules/mod_asis.so
LoadModule auth_basic_module modules/mod_auth_basic.so
LoadModule auth_digest_module modules/mod_auth_digest.so
#LoadModule authn_anon_module modules/mod_authn_anon.so
#LoadModule authn_dbm_module modules/mod_authn_dbm.so
LoadModule authn_default_module modules/mod_authn_default.so
LoadModule authn_file_module modules/mod_authn_file.so
#LoadModule authz_dbm_module modules/mod_authz_dbm.so
LoadModule authz_default_module modules/mod_authz_default.so
LoadModule authz_groupfile_module modules/mod_authz_groupfile.so
LoadModule authz_host_module modules/mod_authz_host.so
LoadModule authz_user_module modules/mod_authz_user.so
LoadModule autoindex_module modules/mod_autoindex.so
#LoadModule cern_meta_module modules/mod_cern_meta.so
LoadModule cgi_module modules/mod_cgi.so
LoadModule dav_module modules/mod_dav.so
LoadModule dav_fs_module modules/mod_dav_fs.so
#LoadModule deflate_module modules/mod_deflate.so
LoadModule dir_module modules/mod_dir.so
LoadModule env_module modules/mod_env.so
#LoadModule expires_module modules/mod_expires.so
#LoadModule file_cache_module modules/mod_file_cache.so
#LoadModule headers_module modules/mod_headers.so
LoadModule imagemap_module modules/mod_imagemap.so
LoadModule include_module modules/mod_include.so
#LoadModule info_module modules/mod_info.so
LoadModule isapi_module modules/mod_isapi.so
LoadModule log_config_module modules/mod_log_config.so
LoadModule mime_module modules/mod_mime.so
#LoadModule mime_magic_module modules/mod_mime_magic.so
#LoadModule proxy_module modules/mod_proxy.so
#LoadModule proxy_ajp_module modules/mod_proxy_ajp.so
#LoadModule proxy_balancer_module modules/mod_proxy_balancer.so
#LoadModule proxy_connect_module modules/mod_proxy_connect.so
#LoadModule proxy_http_module modules/mod_proxy_http.so
#LoadModule proxy_ftp_module modules/mod_proxy_ftp.so
LoadModule negotiation_module modules/mod_negotiation.so
LoadModule rewrite_module modules/mod_rewrite.so
LoadModule setenvif_module modules/mod_setenvif.so
#LoadModule speling_module modules/mod_speling.so
#LoadModule status_module modules/mod_status.so
#LoadModule unique_id_module modules/mod_unique_id.so
LoadModule userdir_module modules/mod_userdir.so
#LoadModule usertrack_module modules/mod_usertrack.so
#LoadModule vhost_alias_module modules/mod_vhost_alias.so
#LoadModule ssl_module modules/mod_ssl.so
LoadModule jk_module modules/mod_jk.so
#LoadModule php5_module "c:/php/php5apache2.dll"
# Load libapreq2 for Apache2::Request etc..
#LoadFile "C:/Apache2/bin/libapreq2.dll"
#LoadModule apreq_module modules/mod_apreq2.so

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org




-----------------------------------------
This communication is for informational purposes only. It is not
intended as an offer or solicitation for the purchase or sale of
any financial instrument or as an official confirmation of any
transaction. All market prices, data and other information are not
warranted as to completeness or accuracy and are subject to change
without notice. Any comments or statements made herein do not
necessarily reflect those of JPMorgan Chase & Co., its subsidiaries
and affiliates.

This transmission may contain information that is privileged,
confidential, legally privileged, and/or exempt from disclosure
under applicable law. If you are not the intended recipient, you
are hereby notified that any disclosure, copying, distribution, or
use of the information contained herein (including any reliance
thereon) is STRICTLY PROHIBITED. Although this transmission and any
attachments are believed to be free of any virus or other defect
that might affect any computer system into which it is received and
opened, it is the responsibility of the recipient to ensure that it
is virus free and no responsibility is accepted by JPMorgan Chase &
Co., its subsidiaries and affiliates, as applicable, for any loss
or damage arising in any way from its use. If you received this
transmission in error, please immediately contact the sender and
destroy the material in its entirety, whether in electronic or hard
copy format. Thank you.

Please refer to http://www.jpmorgan.com/pages/disclosures for
disclosures relating to UK legal entities.

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message