httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Stusynski, Dan" <dstusyn...@ptc.com>
Subject RE: [users@httpd] server listening, not serving pages, no errors logged
Date Wed, 11 Jun 2008 19:38:31 GMT
Did you verify the the port is being listened on with netstat (or similar)?

Out of curiousity, do you have an IPv6 stack on this Win machine, and if so, are you listening
on IPv6 also (using the default Listen 80)? Reason I ask is it sounds similar to an issue
I ran into resulting from IPv6 at one point.

Dan Stusynski 

-----Original Message-----
From: Raul Santiago [mailto:raul@raulsantiago.net] 
Sent: Wednesday, June 11, 2008 2:28 PM
To: users@httpd.apache.org
Subject: Re: [users@httpd] server listening, not serving pages, no errors logged

Sorry for answering to miself, it's just to keep all the information together.
I've been playing with the conf, set enablesendfile and enablemmap to off, changing listening
port... and no success at all. All the symptoms keep the same.

Please, nobody has a clue (as weird as it may sound) about what is wrong?
Thanks.




----- Original Message -----
From: "Raul Santiago" <raul@raulsantiago.net>
To: <users@httpd.apache.org>
Sent: Tuesday, June 10, 2008 3:24 AM
Subject: [users@httpd] server listening, not serving pages, no errors logged


> Hello.
> I've been trying for a few hours to setup an Apache server. I've done it 
> several times before, both under Linux and Win platforms.
> Today, I want to set it up in my notebook, with no success. I've tried 
> different versions (2.0 / 2.2) standalone and integrated into packs (WAMP 
> and AppServ). In all cases, the server starts, the port is listening, and 
> no error comes out in the log, even in debug mode. No hit reachs the 
> access log:
>
> [Tue Jun 10 03:13:59 2008] [notice] Apache/2.2.8 (Win32) PHP/5.2.6 
> configured -- resuming normal operations
> [Tue Jun 10 03:13:59 2008] [notice] Server built: Jan 18 2008 00:37:19
> [Tue Jun 10 03:13:59 2008] [notice] Parent: Created child process 3816
> [Tue Jun 10 03:13:59 2008] [debug] mpm_winnt.c(487): Parent: Sent the 
> scoreboard to the child
> [Tue Jun 10 03:13:59 2008] [notice] Child 3816: Child process is running
> [Tue Jun 10 03:13:59 2008] [info] Parent: Duplicating socket 300 and 
> sending it to child process 3816
> [Tue Jun 10 03:13:59 2008] [debug] mpm_winnt.c(605): Parent: Sent 1 
> listeners to child 3816
> [Tue Jun 10 03:13:59 2008] [debug] mpm_winnt.c(408): Child 3816: Retrieved 
> our scoreboard from the parent.
> [Tue Jun 10 03:13:59 2008] [debug] mpm_winnt.c(564): Child 3816: retrieved 
> 1 listeners from parent
> [Tue Jun 10 03:13:59 2008] [notice] Child 3816: Acquired the start mutex.
> [Tue Jun 10 03:13:59 2008] [notice] Child 3816: Starting 64 worker 
> threads.
> [Tue Jun 10 03:13:59 2008] [notice] Child 3816: Starting thread to listen 
> on port 80.
>
> When I try to access http://localhost or http://127.0.0.1 it just goes 
> on... and on... forever.  If I telnet to the port 80, it gets connection, 
> but I can type whatever (crap or not), I get no headers from httpd.
>
> I tried another web server (cherokee) in the same notebook, and it works 
> perfectly (I tried this to avoid some kind of problem due to firewalls, 
> routing, network devices....)
>
> So please, if any of you have a hint to point me where should I start 
> looking.... I'll be glad to listen and learn.
>
> Thanks in advance.
>
>
> ---------------------------------------------------------------------
> The official User-To-User support forum of the Apache HTTP Server Project.
> See <URL:http://httpd.apache.org/userslist.html> for more info.
> To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
>   "   from the digest: users-digest-unsubscribe@httpd.apache.org
> For additional commands, e-mail: users-help@httpd.apache.org
>
>
> __________ InformaciĆ³n de NOD32, revisiĆ³n 3106 (20080516) __________
>
> Este mensaje ha sido analizado con  NOD32 antivirus system
> http://www.nod32.com
>
> 


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message