httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tan, Liao " <liao....@citi.com>
Subject [users@httpd] Apache 1.3.x issues
Date Mon, 30 Jun 2008 18:39:33 GMT
Folks,
 We´ve been following the steps in http://www.modssl.org/example (Build and install the SSL-aware
Apache), and the following log, when ran the command below:
 
$ ./configure \
    --with-apache=../apache_1.3.41 \
    --with-ssl=../openssl-0.9.8g \
    --prefix=/FlexUAT/busobj/BOBJ6/TESTES/apache

(It´s HP-UX 11, Apache 1.3.x)

Here´s the log:
======================================================
/FlexUAT/busobj/BOBJ6/TESTES/mod_ssl-2.8.31-1.3.41 >>./configure \
> --with-apache=../apache_1.3.41 \
> --with-ssl=../openssl-0.9.8g \
> --prefix=/FlexUAT/busobj/BOBJ6/TESTES/apache

Configuring mod_ssl/2.8.31 for Apache/1.3.41
 + Apache location: ../apache_1.3.41 (Version 1.3.41)
 + OpenSSL location: ../openssl-0.9.8g
 + Auxiliary patch tool: ./etc/patch/patch (local)
 + Applying packages to Apache source tree:
   o Extended API (EAPI)
   o Distribution Documents
   o SSL Module Source
   o SSL Support
   o SSL Configuration Additions
   o SSL Module Documentation
   o Addons
Done: source extension and patches successfully applied.

Configuring for Apache, Version 1.3.41
 + using installation path layout: Apache (config.layout)
Creating Makefile
Creating Configuration.apaci in src
Creating Makefile in src
 + configured for HP-UX 11 platform
 + setting C compiler to gcc
 + setting C pre-processor to gcc -E
 + using "tr [a-z] [A-Z]" to uppercase
 + checking for system header files
 + adding selected modules
    o ssl_module uses ConfigStart/End
      + SSL interface: mod_ssl/2.8.31
      + SSL interface build type: OBJ
      + SSL interface compatibility: enabled
      + SSL interface experimental code: disabled
      + SSL interface conservative code: disabled
      + SSL interface vendor extensions: disabled
      + SSL interface plugin: Configured DBM (-ldbm)
      + SSL library path: /FlexUAT/busobj/BOBJ6/TESTES/openssl-0.9.8g
      + SSL library version: OpenSSL 0.9.8g 19 Oct 2007
      + SSL library type: source tree only (stand-alone)
 + enabling Extended API (EAPI)
 + using system Expat
 + checking sizeof various data types
 + doing sanity check on compiler and options
** A test compilation with your Makefile configuration
** failed.  The below error output from the compilation
** test will give you an idea what is failing. Note that
** Apache requires an ANSI C Compiler, such as gcc.

======== Error Output for sanity check ========
        cd ..; gcc  -DHPUX11 -DMOD_SSL=208131 -DUSE_HSREGEX -DEAPI -DNO_DL_NEEDED `./apaci`
  -L/FlexUAT/busobj/BOBJ6/TESTES/openssl-0.9.8g  -o helpers/dummy helpers/dummy.c   -lm -lpthread
 -ldbm -lssl -lcrypto -lexpat
ld: Can't find library for -ldbm
Fatal error.
collect2: ld returned 1 exit status
*** Error exit code 1

Stop.
============= End of Error Report =============

 Aborting!
./configure:Error: APACI failed
======================================================

Does anyboby know what could be the reason? Please your kind and prompt support, if you know
something about.

Thank you!
Ingrid 



---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message