httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tan, Liao " <liao....@citi.com>
Subject RE: [users@httpd] Not finding the port to HTTPS
Date Fri, 20 Jun 2008 18:02:54 GMT
No problems with the netstat command, I tried with "netstat -a | grep 443" and it brought me:
tcp        0      0  *.443                  *.*                     LISTEN
and several other lines.

Strangely, I did the same with the original port, 4545 (which was already working as http)
and didnt show me anything.
How come?
Anyway, what matters is having the 443 working for my https. When I hit the https url for
2nd time, it shows the padlock, but when right-clicked, says: "This type of document doesnt
have a security certificate", although I have all certificates, configured correctly.

Ingrid 



-----Original Message-----
From: Scott Courtney [mailto:scourtney@sinenomine.net]
Sent: Friday, June 20, 2008 2:32 PM
To: Tan, Liao [CMB-IT]
Cc: users@httpd.apache.org
Subject: RE: [users@httpd] Not finding the port to HTTPS


On Fri, 2008-06-20 at 14:07 -0300, Tan, Liao wrote:
> Hi, Scott and all,
>  Thanks for the hint, I asked the SA to restart it as root, he got no error messages,
and I tried the https in the browser, and still shows the "Page not found". 
>  I ran the command netstat for 443:
> 
> lan: unknown protocol or uninstrumented protocol

Hmmmm....sounds as if your netstat version is a bit different. The
intent of the command is to show everything on port 443. I think your
version of netstat is interpreting "-p" as "show me the following
protocol" and then "lan" as being the argument to the "-p" parameter.
For my version (Debian Linux), "-p" means show the processes owning the
sockets.

Try just "netstat -n | grep :443" and see if that works better. Sorry
for the confusion.

Scott

-- 
Scott Courtney <scourtney@sinenomine.net>
Sine Nomine Associates


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message