httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Joshua Slive" <jos...@slive.ca>
Subject Re: [users@httpd] Apache 2 not serving pages >255 bytes from vxfs filesystem
Date Tue, 20 May 2008 13:07:25 GMT
On Tue, May 20, 2008 at 3:13 AM, Annihilannic <annihilannic@hotmail.com> wrote:
> Hi,
>
> I've encountered a baffling problem trying to serve web pages located on a
> vxfs filesystem.  Files of 255 bytes or less are served fine, but pages of
> 256 bytes or more result in a blank page in FireFox.  If I locate identical
> files on any other kind of filesystem, they work fine.
>
> I'm using the apache2-2.0.59-1.8 RPM under SLES 9 patchlevel 4, x86_64, with
> VRTSvxfs-platform-5.0.10.00-MP1_SLES9.
>
> I compiled the 2.0.63 apache2 source code and the result is the same.  I
> looked through the source code and attempted to track down the problem using
> gdb without success, mainly because I can't identify the ideal location(s)
> to set breakpoints.  I ran httpd with LogLevel "debug" but could see no
> additional messages.  The result codes logged by apache when using FireFox
> as a client are "206 Partial Content", however if I use wget it logs "200
> OK", but wget keeps retrying without actually downloading the web page data.
>
> Does anyone have any theories about the cause of this issue, or suggestions
> to narrow it down?

I can almost guarantee that the problem is a broken sendfile implementation and
EnableSendfile Off
will "fix" it.

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message