httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Anthony Jurado Jr <ajur...@us.ibm.com>
Subject [users@httpd] configure hangs after checking whether SCTP is supported
Date Wed, 07 May 2008 19:41:35 GMT
I'm trying to install the Apache httpd server on a Red Hat Enterprise 
Linux Server release 5.1 (Tikanga).  The output of uname -a is:
Linux server_name 2.6.18-53.1.19.el5 #1 SMP Tue Apr 22 03:01:10 EDT 2008 
x86_64 x86_64 x86_64 GNU/Linux. 

I get the same results for both 2.2.4 and 2.2.8.  Basically, in the 
/opt/httpd-2.2.8 directory I run 
./configure --prefix=/opt/apache2.2.8  --with-included-apr 
or 
./configure --prefix=/opt/apache2.2.8. 

 In both cases configure hangs after echoing " checking whether SCTP is 
supported...".  The process never dies and does not respond to control-c.

The last several lines of output are:
Checking for Networking support...
checking for in_addr in netinet/in.h... yes
checking if fd == socket on this platform... yes
checking style of gethostbyname_r routine... glibc2
checking 3rd argument to the gethostbyname_r routines... char
checking if TCP_NODELAY setting is inherited from listening sockets... yes
checking if O_NONBLOCK setting is inherited from listening sockets... no
checking whether TCP_NODELAY and TCP_CORK can both be enabled... yes
checking for TCP_CORK in netinet/tcp.h... yes
checking for TCP_NOPUSH in netinet/tcp.h... no
checking for SO_ACCEPTFILTER in sys/socket.h... no
checking whether SCTP is supported...

I googled both sctp and 'configure hangs' but did not see any suggestions 
on how to resolve the problem.  Since this is the first time I've tried to 
install Apache on this version of Red Hat I suspect that I need an 
additional RPM, but I don't know which one.

Thanks and Regards,
Tony
Mime
View raw message