httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Murphy <mmu...@cinci.rr.com>
Subject Re: [users@httpd] Install issues
Date Wed, 14 May 2008 12:01:07 GMT
I have done several things to resolve this, but no joy.

1) I tried disabling Windows Personal Firewall
2) I rebooted
3) I changed the logging level to debug

    This resulted in the following log:
    [Wed May 14 07:50:41 2008] [notice] Parent: Received restart signal
    -- Restarting the server.
    [Wed May 14 07:50:41 2008] [notice] Child 2352: Exit event signaled.
    Child process is ending.
    [Wed May 14 07:50:41 2008] [notice] Apache/2.2.8 (Win32) configured
    -- resuming normal operations
    [Wed May 14 07:50:41 2008] [notice] Server built: Jan 18 2008 00:37:19
    [Wed May 14 07:50:41 2008] [notice] Parent: Created child process 1284
    [Wed May 14 07:50:41 2008] [debug] mpm_winnt.c(487): Parent: Sent
    the scoreboard to the child
    [Wed May 14 07:50:42 2008] [info] Child 2352: Accept thread exiting.
    [Wed May 14 07:50:42 2008] [notice] Child 2352: Released the start mutex
    *_[Wed May 14 07:50:42 2008] [info] Child 2352: 64 threads blocked
    on the completion port_*
    [Wed May 14 07:50:42 2008] [notice] Child 1284: Child process is running
    [Wed May 14 07:50:42 2008] [info] Parent: Duplicating socket 772 and
    sending it to child process 1284
    [Wed May 14 07:50:42 2008] [debug] mpm_winnt.c(605): Parent: Sent 1
    listeners to child 1284
    [Wed May 14 07:50:42 2008] [debug] mpm_winnt.c(408): Child 1284:
    Retrieved our scoreboard from the parent.
    [Wed May 14 07:50:42 2008] [debug] mpm_winnt.c(564): Child 1284:
    retrieved 1 listeners from parent
    [Wed May 14 07:50:42 2008] [notice] Child 1284: Acquired the start
    mutex.
    [Wed May 14 07:50:42 2008] [notice] Child 1284: Starting 64 worker
    threads.
    [Wed May 14 07:50:42 2008] [notice] Child 1284: Starting thread to
    listen on port 80.
    [Wed May 14 07:50:43 2008] [notice] Child 2352: All worker threads
    have exited.
    [Wed May 14 07:50:43 2008] [notice] Child 2352: Child process is exiting

    The thing that concerns me here is the part that says "64 threads
    blocked".  What can cause this, or is it a real problem?


Mark Murphy wrote:
> This may or may not be an install issue.  I downloaded the most recent 
> version of Apache 2.2.8 (Win32).  I downloaded the installer, and ran 
> it. This was a clean install as Apache was not on the system 
> previously, and IIS is not on the system either.  My operating system 
> is Windows XP Media Center.
>
> Apache appeared to install properly, and the Monitor indicates that 
> Apache is running properly.  There are no apparent errors in the log.
>
> [Tue May 13 21:29:34 2008] [notice] Apache/2.2.8 (Win32) configured -- 
> resuming normal operations
> [Tue May 13 21:29:34 2008] [notice] Server built: Jan 18 2008 00:37:19
> [Tue May 13 21:29:34 2008] [notice] Parent: Created child process 1636
> [Tue May 13 21:29:35 2008] [notice] Child 1636: Child process is running
> [Tue May 13 21:29:35 2008] [notice] Child 1636: Acquired the start mutex.
> [Tue May 13 21:29:35 2008] [notice] Child 1636: Starting 64 worker 
> threads.
> [Tue May 13 21:29:35 2008] [notice] Child 1636: Starting thread to 
> listen on port 80.
>
>
> The problem is I cannot connect to the server.  When I point my 
> browser at http://localhost/ it just sits there spinning, waiting for 
> something.  If I stop the server I immediately get an Unable to 
> connect error:
>
> Unable to connect
> Firefox can't establish a connection to the server at localhost.
>    *   The site could be temporarily unavailable or too busy. Try 
> again in a few
>          moments.
>    *   If you are unable to load any pages, check your computer's network
>          connection.
>    *   If your computer or network is protected by a firewall or 
> proxy, make sure
>          that Firefox is permitted to access the Web.
>
> Something is happening but I just don't know what.  Can anyone provide 
> some assistance?
>
> BTW, the FAQ said something about making sure that there is a valid 
> ServerName line in the config file, so I made that "localhost".  And 
> the Windows DNS Client service is started.
>
> ---------------------------------------------------------------------
> The official User-To-User support forum of the Apache HTTP Server 
> Project.
> See <URL:http://httpd.apache.org/userslist.html> for more info.
> To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
>   "   from the digest: users-digest-unsubscribe@httpd.apache.org
> For additional commands, e-mail: users-help@httpd.apache.org
>
>
> __________ NOD32 3096 (20080513) Information __________
>
> This message was checked by NOD32 antivirus system.
> http://www.eset.com
>
>
>

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message