httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "syed mehdi" <smmeh...@gmail.com>
Subject [users@httpd] apache module problem
Date Fri, 16 May 2008 11:36:33 GMT
Hi Guys,
I installed latest version of apache (2.2.8) on FC8 (fedora core). i want to
authenticate a script before any user can execute it.
for this effect i made changes in httpd.conf (placed at
"/usr/local/apache2/conf/httpd.conf") and added lines as:
<Directory "/usr/local/apache2/cgi-bin/authenticate">
   AllowOverride AuthConfig
</Directory>

in folder /usr/local/apache2/cgi-bin/authenticate, i created .htaccess and
added following lines in it:
AuthType Basic
AuthName 'LDAP Login (Please do not add prefix before username)'
AuthLDAPUrl ldap://machine-ip:389/ou=people,o=
xyz.com?uid?sub?(objectClass=*)
<Files "authenticate.py">
        require valid-user
</Files>

now whenever i am trying to execute authenticate.py (placed at
/usr/local/apache2/cgi-bin/authenticate)
i am getting the error as:
[Fri May 16 16:32:28 2008] [alert] [client ip]
/usr/local/apache2/cgi-bin/authenticate/.htaccess: Invalid command
'AuthLDAPUrl', perhaps misspelled or defined by a module not included in the
server configuration

Please help

Thanks & regards
Syed

Mime
View raw message