httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From AK...@chrysler.com
Subject RE: [users@httpd] ld.so.1: httpd: fatal: libaprutil-0.so.0: open failed: No such file or directory Killed
Date Thu, 03 Apr 2008 16:19:52 GMT
Thanks Narendra,
Even i had thought of the same but its still the same problem,



Till last week ,this instance was running smoothly but now suddenly it has 
stopped even starting... no error messages anywhere...
DNSname has been registered correctly .
Since  instance first reads the conf file & then runs, i m now getting 
error when i hit the url "http://<ip>:80"  saying "connection refused".If 
instance is not running,then obviously url would fail.

I am trying to check all other probabilities with installation & 
properties file etc .
Just to cross check ,
here is what i found

bash-3.00# svcs -l apache2
fmri         svc:/network/http:apache2
name         Apache 2 HTTP server
enabled      false
state        disabled
next_state   none
state_time   Thu Apr 03 10:49:30 2008
logfile      /var/svc/log/network-http:apache2.log
restarter    svc:/system/svc/restarter:default
contract_id
dependency   require_all/error svc:/milestone/network:default (online)
dependency   require_all/none svc:/system/filesystem/local:default 
(online)
dependency   optional_all/error svc:/system/filesystem/autofs:default 
(online)

Whenever i try to stop server instance (when its not running),i get 
following message,which is obvious:

bash-3.00# ./webs1092 stop
httpd (no pid file) not running

I wonder if httpd daemon process has to be running on my solaris box 
before i start the web server instance.

bash-3.00# ps -ef |grep httpd |grep -v grep
bash-3.00#

Thanks & Regards
Abhijeet



"Narendra Verma" <narendra.verma@impetus.co.in> 
04/03/2008 08:47 PM
Please respond to
users@httpd.apache.org


To
<users@httpd.apache.org>
cc

Subject
RE: [users@httpd] ld.so.1: httpd: fatal: libaprutil-0.so.0: open failed: 
No such file or directory Killed







Hi,
 
Because libaprutil-0.so.0 is not in library path.
 
Just set the path 
 
export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:<directory that contains file 
libaprutil-0.so.0  >
 
for example if your file in 
usr/ucb/ libaprutil-0.so.0
 
 
Then set path 
 
export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:usr/ucb
 
 
Then run your server.
 
Thanks 
Narendra
 
 
 
-----Original Message-----
From: AK835@chrysler.com [mailto:AK835@chrysler.com] 
Sent: Thursday, April 03, 2008 8:38 PM
To: users@httpd.apache.org
Subject: [users@httpd] ld.so.1: httpd: fatal: libaprutil-0.so.0: open 
failed: No such file or directory Killed
 

Friends, 
I have installed IBM http server 6.0 on solaris 5.10.It installs 
successfully but i am unable to start the web server instance i have 
created. 
Also i tried running commands written in shell executable ,which starts 
this web server instance,i got following message. 

Any ideas on this : 

bash-3.00# pwd 
bash-3.00# /global/site/vendor/IHS/6.0/bin 
bash-3.00# ./webs1092 start 
bash-3.00# (returns to prompt) 

but if i run executable line by line,i get this error 

ld.so.1: httpd: fatal: libaprutil-0.so.0: open failed: No such file or 
directory 
Killed 


Thanks & Regards
Abhijeet Kulkarni 

Mime
View raw message