httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "j k" <jonnyk...@gmail.com>
Subject [users@httpd] basic authentication: AuthUserFile directive not recognized apache2.2
Date Tue, 08 Apr 2008 18:27:39 GMT
Recently upgraded from 2.0.59 to 2.2.8 and awstats no longer works.
Digging deeper found that my awstats.conf was out of date and had not been
included in httpd.conf.

After including awstats.conf in httpd.conf discovered that mod_auth.c has
been replaced by mod_authn.c which is now part of the base.
So after taking out the <IfModule mod_ath.c> statements on configtest apache
balks at the AuthUserName directive:

 * Apache2 has detected a syntax error in your configuration files:
Syntax error on line 93 of /etc/apache2/awstats.conf:
Invalid command 'AuthUserFile', perhaps misspelled or defined by a module
not included in the server
configuration                                        [ !! ]

Here's the snippet where AuthUserFile is used:

<Directory "/usr/share/webapps/awstats/6.5-r2/hostroot">
  Options None
  AllowOverride None
  Order allow,deny
  Allow from all
  AuthType Basic
  AuthName AWStats
  AuthUserFile /etc/awstats/users.pwd
  require valid-user
</Directory>

This used to work fine under 2.0.59 so I'm a little confused as to what is
happening here now.
Thanks for your help.

Mime
View raw message