httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ch Praveena" <ps050...@gmail.com>
Subject [users@httpd] When apache 2.0.63 is used as load balancer...,
Date Wed, 30 Apr 2008 07:29:06 GMT
Hi all .,

             I want to cluster Jboss by using apache server(httpd 2.0.63 )
as load balancer. When I tried to do this, I found the log files as
follows..

* mod_jk.log file of apache*

[root@localhost logs]# tail -f mod_jk.log
[Wed Apr 30 11:56:08 2008][3345:3086427840] [error] init_jk::mod_jk.c
(2781): Initializing shm:/usr/local/apache2/run/jk.shm.3345 errno=2. Load
balancing workers will not function properly.
[Wed Apr 30 11:56:08 2008][3345:3086427840] [warn]
jk_map_validate_property::jk_map.c (410): The attribute
'worker.node1.cachesize' is deprecated - please check the documentation for
the correct replacement.
[Wed Apr 30 11:56:08 2008][3345:3086427840] [warn]
jk_map_validate_property::jk_map.c (410): The attribute
'worker.node2.cachesize' is deprecated - please check the documentation for
the correct replacement.
[Wed Apr 30 11:56:08 2008][3345:3086427840] [info] init_jk::mod_jk.c (2825):
mod_jk/1.2.26 initialized
[Wed Apr 30 11:59:14 2008]loadbalancer 10.20.220.135 0.961028
[Wed Apr 30 11:59:14 2008]loadbalancer 10.20.220.135 0.016325
[Wed Apr 30 11:59:19 2008]loadbalancer 10.20.220.135 4.573659
[Wed Apr 30 11:59:19 2008]loadbalancer 10.20.220.135 0.023416
[Wed Apr 30 11:59:19 2008]loadbalancer 10.20.220.135 0.023957
[Wed Apr 30 11:59:19 2008]loadbalancer 10.20.220.135 0.139374


*
error_log file of apache*

[root@localhost logs]# tail -f error_log
[Wed Apr 30 11:53:16 2008] [notice] Apache/2.0.63 (Unix) mod_jk/1.2.26
configured -- resuming normal operations
[Wed Apr 30 11:56:07 2008] [notice] caught SIGTERM, shutting down
[Wed Apr 30 11:56:08 2008] [notice] Apache/2.0.63 (Unix) mod_jk/1.2.26
configured -- resuming normal operations
[Wed Apr 30 11:59:07 2008] [error] [client 10.20.220.15] File does not
exist: /usr/local/apache2/htdocs/favicon.ico
[Wed Apr 30 11:59:14 2008] [error] [client 10.20.220.15] File does not
exist: /usr/local/apache2/htdocs/favicon.ico



*access_log file of apache*

[root@localhost logs]# tail -f access_log
10.20.220.15 - - [30/Apr/2008:11:59:07 +0530] "GET / HTTP/1.1" 200 1456
10.20.220.15 - - [30/Apr/2008:11:59:07 +0530] "GET /apache_pb.gif HTTP/1.1"
200 2326
10.20.220.15 - - [30/Apr/2008:11:59:07 +0530] "GET /favicon.ico HTTP/1.1"
404 300
10.20.220.15 - - [30/Apr/2008:11:59:13 +0530] "GET /casper-2.1/app HTTP/1.1"
200 729
10.20.220.15 - - [30/Apr/2008:11:59:14 +0530] "GET
/casper-2.1/app?serviceId=Echo.ClientEngine HTTP/1.1" 200 10767
10.20.220.15 - - [30/Apr/2008:11:59:14 +0530] "GET /favicon.ico HTTP/1.1"
404 300
10.20.220.15 - - [30/Apr/2008:11:59:14 +0530] "POST
/casper-2.1/app?serviceId=Echo.Synchronize HTTP/1.1" 200 3435
10.20.220.15 - - [30/Apr/2008:11:59:19 +0530] "GET
/casper-2.1/app?serviceId=Echo.ContentPane HTTP/1.1" 200 809
10.20.220.15 - - [30/Apr/2008:11:59:19 +0530] "GET
/casper-2.1/app?serviceId=Echo.WebContainer HTTP/1.1" 200 609
10.20.220.15 - - [30/Apr/2008:11:59:19 +0530] "GET
/casper-2.1/app?serviceId=22fe09_1199e06b43f_1 HTTP/1.1" 200 11333



Please let me know where I might have gone wrong with the load balancer..

Here are the file details:

VERSION- jboss 4.2.2.GA
APACHE- httpd 2.0.63

uriworkersmap.properties file

# Simple worker configuration file
#

# Mount the Servlet context to the ajp13 worker

/casper-2.1=loadbalancer

/casper-2.1/*=loadbalancer

/web-console=loadbalancer
/web-console/*=loadbalancer






workers.properties
# Define list of workers that will be used
# for mapping requests
# The configuration directives are valid
# for the mod_jk version 1.2.18 and later
#
worker.list=loadbalancer,status

# Define Node1
# modify the host as your host IP or DNS name.
worker.node1.port=8009
worker.node1.host=10.20.220.15
worker.node1.type=ajp13
worker.node1.lbfactor=1
# worker.node1.connection_pool_size=10 (1)

# Define Node2
# modify the host as your host IP or DNS name.
worker.node2.port=8009
worker.node2.host= 10.20.220.3
worker.node2.type=ajp13
worker.node2.lbfactor=1
# worker.node1.connection_pool_size=10 (1)

# Load-balancing behaviour
worker.loadbalancer.type=lb
worker.loadbalancer.balance_workers=node1,node2
worker.loadbalancer.sticky_session=1

# Status worker for managing load balancer
worker.status.type=status


Is that cache size attribute correct??






-- 
Regards,

Praveena Chalamcharla,
Securview....

Mime
View raw message