httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Narendra Verma <narendra.ve...@impetus.co.in>
Subject RE: [users@httpd] Multiple processes are running when start apache2.2.8 on solaris2.9 machine
Date Wed, 30 Apr 2008 05:59:42 GMT
Hi,
Thanks for you reply.
You asked two point:
1. This is solaris2.9
2. Server MPM
bash-2.05$ ./apachectl -V
Server version: Apache/2.2.8 (Unix)
Server built:   Apr 29 2008 15:42:35
Server's Module Magic Number: 20051115:11
Server loaded:  APR 1.2.12, APR-Util 1.2.12
Compiled using: APR 1.2.12, APR-Util 1.2.12
Architecture:   32-bit
Server MPM:     Prefork
  threaded:     no
    forked:     yes (variable process count)
Server compiled with....
 -D APACHE_MPM_DIR="server/mpm/prefork"
 -D APR_HAS_SENDFILE
 -D APR_HAS_MMAP
 -D APR_HAVE_IPV6 (IPv4-mapped addresses enabled)
 -D APR_USE_FCNTL_SERIALIZE
 -D APR_USE_PTHREAD_SERIALIZE
 -D SINGLE_LISTEN_UNSERIALIZED_ACCEPT
 -D APR_HAS_OTHER_CHILD
 -D AP_HAVE_RELIABLE_PIPED_LOGS
 -D DYNAMIC_MODULE_LIMIT=128
 -D HTTPD_ROOT="/export/home/Apache2.2.8"
 -D SUEXEC_BIN="/export/home/Apache2.2.8/bin/suexec"
 -D DEFAULT_PIDLOG="logs/httpd.pid"
 -D DEFAULT_SCOREBOARD="logs/apache_runtime_status"
 -D DEFAULT_LOCKFILE="logs/accept.lock"
 -D DEFAULT_ERRORLOG="logs/error_log"
 -D AP_TYPES_CONFIG_FILE="conf/mime.types"
 -D SERVER_CONFIG_FILE="conf/httpd.conf"

Please guide me to resolve that.
Thanks
Narendra
-----Original Message-----
From: Antonio Vidal Ferrer [mailto:antonio.vidal@globalia-sistemas.com]
Sent: Tuesday, April 29, 2008 9:27 PM
To: users@httpd.apache.org
Subject: RE: [users@httpd] Multiple processes are running when start apache2.2.8 on solaris2.9
machine

Can you please specify:


1.       Solaris 9 sparc or intel?

2.       Which MPM do you have? Worker or Prefork? This can be obtained with apachectl -V

Best



From: Narendra Verma [mailto:narendra.verma@impetus.co.in]
Sent: martes, 29 de abril de 2008 17:02
To: 'users@httpd.apache.org'
Subject: [users@httpd] Multiple processes are running when start apache2.2.8 on solaris2.9
machine

Hi all,
I just installed apache2.2.8 on solaris2.9 and configured properly.
But when test to apache while is it running or not.
So I got its running properly but problem  is it starts multiple httpd processes.
This what I got basically.
Can any body tell me that why it is starting multiple processes.

I attached my httpd.conf with this mail  file if want to read.

Command run by me are : -

bash-2.05$ ./httpd -k start
bash-2.05$ ps -edaf |grep infra
   infra 19205 19201  0 20:24:27 ?        0:00 ./httpd -k start
   infra 19202 19201  0 20:24:27 ?        0:00 ./httpd -k start
   infra 19167 19165  0 20:22:01 pts/1    0:00 -sh
   infra 19206 19201  0 20:24:27 ?        0:00 ./httpd -k start
   infra 19207 19171  0 20:24:34 pts/1    0:00 ps -edaf
   infra 19201     1  1 20:24:27 ?        0:00 ./httpd -k start
   infra 19204 19201  0 20:24:27 ?        0:00 ./httpd -k start
   infra 19203 19201  0 20:24:27 ?        0:00 ./httpd -k start
   infra 19208 19171  0 20:24:34 pts/1    0:00 grep infra
   infra 19171 19167  0 20:22:06 pts/1    0:00 bash
   infra 11511     1  0   Mar 14 ?        0:00 sh /export/home/infra/CH312/bin/jacjavavm -Dorg.omg.CORBA.ORBClass=org.jacorb.o
   infra 11513 11511  0   Mar 14 ?        0:35 /export/home/infra/install/jdk1.5.0_12/bin/java
-server -Xmx512m -DORB.Provider
bash-2.05$ ./httpd -k stop
bash-2.05$ ps -edaf |grep infra
   infra 19167 19165  0 20:22:01 pts/1    0:00 -sh
   infra 19217 19171  0 20:25:44 pts/1    0:00 grep infra
   infra 19216 19171  0 20:25:44 pts/1    0:00 ps -edaf
   infra 19171 19167  0 20:22:06 pts/1    0:00 bash
   infra 11511     1  0   Mar 14 ?        0:00 sh /export/home/infra/CH312/bin/jacjavavm -Dorg.omg.CORBA.ORBClass=org.jacorb.o
   infra 11513 11511  0   Mar 14 ?        0:35 /export/home/infra/install/jdk1.5.0_12/bin/java
-server -Xmx512m -DORB.Provider
bash-2.05$

Please reply, its urgent.

Thanks in advance
Narendra

Mime
View raw message