httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Steve Finkelstein" ...@stevefink.net>
Subject [users@httpd] Logging mod_deflate compression ratios
Date Fri, 14 Mar 2008 20:34:14 GMT
Hi all,

I'm trying to log actual ratios of Compression that mod_deflate is
responsible for handling. I've followed the guidelines on Apache's
site and have the following directives setup:

DeflateFilterNote Input instream
DeflateFilterNote Output outstream
DeflateFilterNote Ratio ratio

SetOutputFilter DEFLATE
SetEnvIfNoCase Request_URI \.(?:gif|jpe?g|png)$ no-gzip dont-vary
Header append Vary User-Agent env=!dont-vary
DeflateCompressionLevel 9

LogFormat '"%r" %{outstream}n/%{instream}n (%{ratio}n%%)' deflate
CustomLog logs/deflate_log deflate


After restarting Apache, I unfortunately only see the following in deflate_log:

argon logs # cat deflate_log
"GET / HTTP/1.0" -/- (-%)
"GET / HTTP/1.0" -/- (-%)
"GET / HTTP/1.0" -/- (-%)
"GET / HTTP/1.0" -/- (-%)
"GET / HTTP/1.0" -/- (-%)
"GET / HTTP/1.0" -/- (-%)


etc.

Any idea on what I'm possibly doing wrong?

/sf

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message