httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Joshua Slive" <jos...@slive.ca>
Subject Re: [users@httpd] Wrong default character setting when list file(Options Indexes)
Date Mon, 24 Mar 2008 13:47:13 GMT
On Mon, Mar 24, 2008 at 3:31 AM,  <ccyen@ascc.net> wrote:
> Hi
>       I have a problem when I tried to migrate data from apache 1.3 to
> apache 2.0
>
>  I need to list all my file in public_html(just set "Options Indexes" to
> enable it)
>
>  With Apache 2.0
>  I found that all filename with chinese (big5) are wrong character
> setting(ISO-8859) in my browser(firefox).
>  It's ok if I change the character setting in my browser,
>  but after refreshing the page with F5,
>  the character setting chage back to ISO-8859
>
>  But it's all OK in the Apache 1.3
>
>  I want to know how to set the default character setting to what I want in
> the apache conf ?
>
>
>  I have tried to add these setting
>
>  DefaultLanguage zh-TW
>  LanguagePriority zh-TW
>  AddDefaultCharset Big5
>
>  but this problem is still there....
>
>  Could anyone give me a suggestion?

Try
IndexOptions charset=Big5

See:
http://httpd.apache.org/docs/2.0/mod/mod_autoindex.html#indexoptions

Joshua.

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message