httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Joshua Slive" <jos...@slive.ca>
Subject Re: [users@httpd] Re: apache process locks at 100% cpu usage
Date Wed, 19 Mar 2008 19:30:57 GMT
On Wed, Mar 19, 2008 at 10:42 AM, Evert Lammerts
<evert.lammerts@gmail.com> wrote:
> And how about this: after benchmarking apache with ab -c 100 -n 10000 an
>  apache process is left in the process list for a while with <defunct>
>  appended - it disappears after a minute or so.
>
>  If I benchmark the server from two different machines with two different
>  requests, apache locks up, the benchmarks time out and the server is
>  left with a process list filled with apache2 processes that need to be
>  killed with killall. It does seem to be a concurrency problem but I
>  can't figure out where it comes from. Any help would be great!

Session locking?

This is almost surely some kind of lock contention in your php code.
You can grab a live backtrace of a "stuck" process to see where the
problem is:
http://httpd.apache.org/dev/debugging.html#backtrace

Joshua.

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message