httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dinesh Kumar" <pdine...@elitmus.com>
Subject [users@httpd] Access is slow when accessed by IP address instead of 'localhost'
Date Tue, 11 Mar 2008 11:28:33 GMT
Hi all,

I'm facing a peculiar problem.  My environment is as follows:

Apache 2.2.4
mod_jk 1.2.23
Tomcat 6.0.13

When I access the Java application running on Tomcat like this:  curl
http://localhost/community/forums/list.page, I get a response within 1
second.  However, when I access it like this:
http://192.168.1.2/community/forums/list.page, the response takes 10
seconds.

To be clear, in both the cases I'm accessing the application from the *same*
machine that runs httpd/tomcat.  I found out about this issue when I tried
to access it from another machine on the same LAN, which is how it will be
actually accessed when the issue is resolved. I tried to find out what
happened when I accessed it from the same machine on which it is running,
and found that it behaves similarly as I mentioned above.

192.168.1.2 is on eth0, and eth0 is setup as a trusted device.  When I
access another Tomcat 6 application running locally like this: curl
http://192.168.1.2/recruit/admin, the request is served instantly.

The extra time occurs between the following lines of mod_jk.log:

[Mon Mar 10 17:03:54 2008] [7071:60304] [debug]
ajp_send_request::jk_ajp_common.c (1287): (forum) request body to send 0 -
request body to resend 0
[Mon Mar 10 17:04:04 2008] [7071:60304] [debug]
ajp_connection_tcp_get_message::jk_ajp_common.c (1043): received from ajp13
pos=0 len=133 max=8192

I thought it was something to do with mod_jk and installed version 1.2.26,
but the problem persists.

Any pointers would be welcome!

Thanks,
Dinesh.

Mime
View raw message