httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Scott Courtney <scourt...@sinenomine.net>
Subject Re: [users@httpd] xml
Date Tue, 25 Mar 2008 16:14:25 GMT
On Tuesday 25 March 2008 10:18:07 Melanie Pfefer wrote:
> hello
> 
> the page property is when I right-click on the IE page
> and click on "page property"
> 
> from a linux server:
> Content-Type: text/plain
> 
> I suspect that some configuration is overriding this
> AddType. Could it be that cause?
> thanks

Do you have the MIME module loaded? What is the output when you run Apache's
daemon with the "-M" option?

If you have mime.module loaded, then you may have a config line like this:

TypesConfig /etc/httpd/mime.types

The mime.types file contains declarations for dozens of file types.

Where in your config are you declaring your AddType line? Perhaps you have the
desired line at the global level but are overriding it in the virtual host.

Also...I probably should have asked this before, but is the page simply a
static XML file (foo.xml) on the server, or are you generating it with CGI,
Perl, PHP, etc.? In the latter case, the application may be sending its own
Content-Type header.

Scott

-- 
-----------------------------------------------------------------------------
Scott D. COURTNEY, Principal Engineer                  Sine Nomine Associates
scourtney@sinenomine.net                           http://www.sinenomine.net/

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message