httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nilesh Govindrajan <ad...@itech7.com>
Subject Re: [users@httpd] Access is slow when accessed by IP address instead of 'localhost'
Date Tue, 11 Mar 2008 14:18:47 GMT
On Tue, 11 Mar 2008 09:10:16 -0500
"Adam Martin" <Adam.Martin@infor.com> wrote:

> Dinesh,
> 
>  
> 
> When I started reading I thought you may be experiencing a delay with
> the host resolution but when you mentioned that you could access
> another Tomcat application using the IP Address it doesn't sound like
> you are.
> 
>  
> 
> To be sure you may want to add the 192.168.1.2 host to your hosts file
> on the server and make sure the server is set to resolve names locally
> before accessing DNS to see if it makes any difference.  Other than
> that I got zip.  Good luck.
> 
>  
> 
> ________________________________
> 
> From: Dinesh Kumar [mailto:pdineshk@elitmus.com] 
> Sent: Tuesday, March 11, 2008 6:29 AM
> To: users@httpd.apache.org
> Subject: [users@httpd] Access is slow when accessed by IP address
> instead of 'localhost'
> 
>  
> 
> Hi all,
> 
> I'm facing a peculiar problem.  My environment is as follows:
> 
> Apache 2.2.4
> mod_jk 1.2.23
> Tomcat 6.0.13
> 
> When I access the Java application running on Tomcat like this:  curl
> http://localhost/community/forums/list.page, I get a response within 1
> second.  However, when I access it like this:
> http://192.168.1.2/community/forums/list.page, the response takes 10
> seconds.
> 
> To be clear, in both the cases I'm accessing the application from the
> *same* machine that runs httpd/tomcat.  I found out about this issue
> when I tried to access it from another machine on the same LAN, which
> is how it will be actually accessed when the issue is resolved. I
> tried to find out what happened when I accessed it from the same
> machine on which it is running, and found that it behaves similarly
> as I mentioned above.
> 
> 192.168.1.2 is on eth0, and eth0 is setup as a trusted device.  When I
> access another Tomcat 6 application running locally like this: curl
> http://192.168.1.2/recruit/admin, the request is served instantly.
> 
> The extra time occurs between the following lines of mod_jk.log:
> 
> [Mon Mar 10 17:03:54 2008] [7071:60304] [debug]
> ajp_send_request::jk_ajp_common.c (1287): (forum) request body to
> send 0
> - request body to resend 0
> [Mon Mar 10 17:04:04 2008] [7071:60304] [debug]
> ajp_connection_tcp_get_message::jk_ajp_common.c (1043): received from
> ajp13 pos=0 len=133 max=8192
> 
> I thought it was something to do with mod_jk and installed version
> 1.2.26, but the problem persists.
> 
> Any pointers would be welcome!
> 
> Thanks,
> Dinesh.
> 

According to me, an IP address doesn't need the DNS to resolve
something.

-- 
Nilesh G
India Technologies Administrator
www.itech7.com

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message