httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Joshua Slive" <jos...@slive.ca>
Subject Re: [users@httpd] Flock issue? Further debug help needed
Date Tue, 26 Feb 2008 14:21:04 GMT
On Tue, Feb 26, 2008 at 6:22 AM, Rudy Gevaert <Rudy.Gevaert@ugent.be> wrote:
> Hello,
>
>  At our site we are running several Apache2 (Debian Etch) installations.
>   These our mounting a NFS share (Netapp).  The Apache webservers are
>  behind a Linux Virtual server setup.
>
>  Sometimes we see that one of the apache webservers is hung.  It still
>  listens on port 80 but doesn't do anything with the incoming
>  connections.  Only restarting apache fixes it.
>
>  When I do a strace on the apache processes I see:
>  flock(14, LOCK_EX <unfinished ...>
>
>  Having a look at the that process its file descriptor:
>
>  tygra:/proc/14# ls -l /proc/18836/fd/14
>  lrwx------ 1 root root 64 Feb 26 09:27 /proc/18836/fd/14 ->
>  /icto/tmp/sess_0bbf26140aa44a83e3c5c11afc0ca1b1

Can you figure out what file this is pointing at?

My guess would be nfs problems. Have you pointed LockFile at a local disk?

Joshua.

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message