httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Joshua Slive" <jos...@slive.ca>
Subject Re: [users@httpd] Webdav through webfolder in xp problem
Date Thu, 21 Feb 2008 14:25:29 GMT
On Thu, Feb 21, 2008 at 5:58 AM, Richard Smith <rich.smith1982@gmail.com> wrote:
> Hi
>
> I've recently installed apache on our server, and then added a webdav
> folder, which was then made accessilbe through XP. I had no problems with
> authentication, however if I try and open a PDF, text file, or any kind of
> image by double clicking on the file in the folder view in XP, they don't
> open. For text files and pdf's I get the following:
>
> "There was an error opening this document. The filename, directory name, or
> volume label syntax is incorrect."
>
>
> However, if I open the file via it's required program, i.e adobe reader, by
> navigating to the webfolder via File->Open, the file opens without any
> problems.
>
> Office documents open without any problem, so any ideas on what is going on?
> Any help would be much appreciated!

You can check the apache error and access logs for any problems. But
to the best of my recollection, this is a weakness in XP's
implementation of DAV and is expected behavior. XP webfolders are not
true remote filesystems. In other words, they don't allow you to treat
the DAV location just like any other folder. Some programs (like
Office) has explicit support for DAV and therefore work correctly;
others don't.

Joshua.

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message