httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Joshua Slive" <jos...@slive.ca>
Subject Re: [users@httpd] HTTPD won't start. Fails with error message.
Date Fri, 15 Feb 2008 23:22:58 GMT
On Fri, Feb 15, 2008 at 6:19 PM, Mike - W0TMW <mikew@crucis.net> wrote:
> I'm building a server based on Fedora 7 and httpd won't start.  I'm
>  running out of space on another server and this one is intended as a
>  replacement.  I've looked through the archives, FAQs and while this
>  issue is mentioned, that's all I can find---a mention with no help for
>  resolution.
>
>  The error is:
>
>  Starting httpd: (98)Address already in use: make_sock: could not bind to
>  address 192.168.1.300:80 No listening sockets available, shutting down.
>  Unable to open logs              [Failed]
>
>  I have another webserver that works just fine.  The log directory have
>  identical owners/groups permissions so there shouldn't a permissions
>  problem for the logfiles.  Plus the httpd.conf is identical. One works
>  the other servers doesn't.
>
>  Could anyone point me towards resolving this?

I believe the "Unable to open logs" is a red-herring caused by
Redhat's startup script. The real error is just above it. Help with
debugging the error is here:
http://wiki.apache.org/httpd/CouldNotBindToAddress

Joshua.

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message