httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Joshua Slive" <jos...@slive.ca>
Subject Re: [users@httpd] XML/XLS filtering
Date Thu, 14 Feb 2008 18:32:12 GMT
On Thu, Feb 14, 2008 at 1:27 PM, Andrew2008
<kingdom2dominion@hotmail.com> wrote:
>
>
>
>  PingBad wrote:
>  >
>  > Have you tried the DefaultType
>  > [http://httpd.apache.org/docs/2.2/en/mod/core.html#defaulttype] directive?
>  >
>
>  I changed the defaulttype directive but it still does not render correctly.
>  The good news is when I did a view source, it looked like it has all html
>  elements in it like javascript, table, div, images, etc...  So it is a valid
>  html document but the tables, div, images and all those things don't render
>  correctly on the front end.  I wonder if I need to add html module or
>  something like that in apache so it can understand html documents????

The problem is almost-certainly that your application is sending the
wrong Content-Type header. For instructions on how to look at the
header, see:
http://wiki.apache.org/httpd/WatchingHttpHeaders

That leaves open the question of WHY the wrong content-type is being
sent. If you want help about that, you need to give us some details on
exactly what process is generating the content and how it is related
to apache. A simple list of loaded modules doesn't tell us anything at
all.

Joshua.

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message