httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Joshua Slive" <jos...@slive.ca>
Subject Re: [users@httpd] failed because search permissions are missing on a component of the path
Date Wed, 13 Feb 2008 14:38:04 GMT
On Feb 13, 2008 8:48 AM, Carlos Eduardo Maiolino <maiolinux@gmail.com> wrote:
> Hello friends.
>
> I have a webserver with 100 web sites in VirtualHosts, but one site only
> don't have permission to display image files in any browser.
> In Apache error Log, the message is:
>
> "[Wed Feb 13 11:40:51 2008] [error] [client 123.123.123.123] (13)Permission
> denied: access to /foo/pictures/picture.jpg failed because search
> permissions are missing on a component of the path"
>
> I'm checked the File permissions, and I'm setted 777 in the all directory of
> this site, but this don't solve my problem.

Check every directory from where the file is located all the way up to
the root. It is likely one of the parent directories that doesn't have
search (+x) permission for the apache user.

Joshua.

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message